Media player- no sounds, wave files are flat line


#1

I think I asked this question sometime in the past but can’t find the post. So the issue is that although I can record midi and audio files from my keyboard, the result is no sound on playback. the audio profile for the audio file is a flat line. I’ve just reinstalled Windows and all my software. Everything seems to be working fine except this is with media player playback.

By the way, previously recorded audio files play ok.


#2

So this is a problem with recording and not playback right?

Most likely you haven’t selected the correct audio ports to record. Go to View -> Side Panel -> Recorder Ports and make sure you’ve selected the correct ports. eg: Main Speakers.


#3

thanks Brad. That took care of it.


#4

I’m still having some issues with this. I can record and play back midi files using Cantabile media player. I can record audio files. I see the transport bar moving across the file but there is no sound (I know they have recorded because I can see the wave profile for the file). I can open the audio file in a different media app (VLC) and it plays ok. See link for my screen set up. I can load other audio files (wav, mp3) and they play just fine. What am I missing


#5

Hi Lee,

I checked out your pic and it has a MIDI file loaded, so I’m confused. Are you have trouble playing back Audio files or MIDI files? If they are audio do the meters bounce for the media player when the track plays?

Dave


#6

Yea, I did have a midi file loaded when I took the screen shot but the problem is with playing audio files I’ve recorded recently (since Windows and Cantabile were reinstalled). The meters do move


#7

OK thanks, and you say that other mp3 files play back in the same player, just not the recorded wav files you loaded after recording them. Correct?


#8

Yes, that’s right. No sound for recently record audio


#9

Are you loading via drag and drop or using the import function on the recordings pane? Try emptying the playlist for the mediaplayer and then drag the same audio file from windows explorer Canatabile racordings folder directly onto the media player. If that fixes it then Brad should know about this quirk.

Dave


#10

made no difference either way


#11

I have to defer to @brad on this one Lee, it’s working ok here.

Dave


#12

Hi @LeesKeys

Not sure what might be going on here. A couple of things to check:

  1. Try turning on only the one audio port in Recorder Ports panel, turn on Auto Record (right click on the record button), start playing and see if the recorder starts.
  2. Double check you’ve selected the correct port - go to the Monitor panel and check which port is lighting up when you play and make sure that’s the port that’s selected in the recorder ports panel.
  3. Try opening the recorded audio file in Audacity and see if the recorded audio is ending up on different channels - eg: on channels 3/4 instead of 1/2.

Failing all that, send me a copy of your settings.json file (from Tools -> Open Settings Folder) and I’ll see if I can spot the problem.

Brad


#13

I unchecked everything on the Recorder panel except Main keyboard (input) and Main Speakers (output). The recorded file now has audio output. It seems the problem port was having main microphone (audio input) also checked. With that, no sound from my audio file.
Is something still not right or did I just have the settings wrong?


#14

If you have multiple audio ports selected in the recorder ports panel then all those ports should be recorded to the same audio file. In your case Main Microphone should have been recorded to channel 1/2 and Main Speakers to channel 3/4.

It’d be interesting to open one of your older flat-line recordings in Audacity and see if there’s anything on channel 3/4.

That said, I think Cantabile’s time line should have shown something even if on channel 3/4.

Brad


#15

I deleted a lot of the recordings files. I pulled one out of the recycle bin, reloaded it into Cantabile media player. It has a waveform, but no sound. When I open it in Audacity, it does produce sound on channel 3/4.

So I guess I don’t have media player set up correctly?


#16

Well better to configure the recorder to only record the channels you need, but yes, if you want to playback channels 3/4 in Cantabile’s media player, do this:

  1. Load the media file into a media player
  2. Right click on the media player slot and choose “Edit Current File Settings” and take a look at the Port Assignments section. It’s probably like this, which means send your silent channels 1 and 2 to the media player’s Stereo Out port.

image

Double click on each assignment and change the source channels to 3/4 and it’ll work. You want it like this:

image

PS: I just noticed that while it’s usable, there’s some weird flickering going on in the window where you edit the assignments - I’ll get that fixed for the next build.