Media Player Midi Loop Playing

Tags: #<Tag:0x00007f97854e0290>

Hi all

I encounter the following issue. I would like to loop a Midi file to trigger e.g. the Superior Drummer VST.
My Midi file has a set tempo of e.g. 120bpm
Let’s say I want a different song tempo of e.g. 100 bpm

I do set a binding to the Media Player that at “On End of Track/Range” it should re-play again
If I set the Sync Mode of the Media Player to “Slave/RealTime”, the midi file loops, but does not adapt to the song tempo. This is the correct behaviour.

If I set the Sync Mode of the Media Player to “Slave/Musical” it adapts to the song tempo, but the midi file does not loop.

Should the Slave/Musical setting also not loop, or how do I get it to loop?

Sure, a workaround is to modify the Midi file’s tempo to the song tempo and use the modified Midifile, but I hope the “Musical” Sync mode would adapt to the tempo AND loop, when set to loop.

Thanks for helping

Ad

You could use Topiary Beatz - it follows the host’s BPM (if you want - you can disable that as well). Open source and free :slight_smile: .

https://topiaryplugins.wordpress.com/topiary-beatz/

1 Like

@Tom_Tollenaere,

I installed Topiary Beatz, but have an issue that Cantabile does not recognize it, neither after a quick scan nor after a full re-scan. In Reaper I also cannot use it. I am the only one in Windows having these issues, or is something wrong?

Ad

That is strange - when did you download it? You are sure it is in your VST folder of course? I’ll doublecheck the version on github in an hour or so to see what’s up.

Sure it is in my VST folder (I have way too many plugins…)
As said my Cantabile (latest 64bit Windows version) does not recognize it
In the latest Reaper I get the enclosed error message

Running a freshly donwload topiary beatz.dll from your github

The one on github did not work on my machines either. I re-uploaded a minute ago and the current version works for me (actually, it’s still version 1.1.1 dd March 23 but for some reason the copy that was on Github till 2 minutes ago fails). Apologies & tx for letting me know.

1 Like

I still get the same error with Reaper; can’t check Cantabile at the moment; are you sure the new version is uploaded?

Here it is running in Cantabile - fresh download from github 5 minutes ago.

Here it is in Reaper - same plugin.

I tried on my desktop (this one) which did not have older versions (I don’t make music on it) but also did this on my main Cantabile machine … Strange.

On github you can find several older versions as well. Have you tried version 1.1.0 for example? I have no idea why it would run on my machines and not on yours. I am assuming your windows version is up2date? 64Bit? I will do some more digging over the weekend.

Still no success. I downloaded the latest Topiary Beatz yesterday evening from your github, but Cantabile does not recognize it properly: I see it passing by in the scan, but it does not show up in the plugin lists

I am on windows 10 64 bit, but not the latest update; I think I have still an early 2020 version

OK, 2 things. The only thing I can think of is perhaps you do not have the Microsoft C++ redistributables installed on you machine. As far as I know Win10 should include those automatically these days but that was not always the case. Here is a download link:
https://support.microsoft.com/en-us/topic/the-latest-supported-visual-c-downloads-2647da03-1eea-4433-9aff-95f26a218cc0

I will also - probably tonight - post a new version 1.1.2 in which minor things were tweaked for randomisation of velocity and timing. If your issue is not the above it probably won’t make a difference but heck worth a shot.

Let me know if you issue happens to be the redistributables - I have not know this to happen for more than 2 years (the download page used to warn for this condition but afaik that should be a non-issue today – I may be wrong … and if I am I will re-post the warning about that.)

@adderoo - I put up a new version. It has minor tweaks but nothing was changed that should make it run-or-not on your machine. Do you mind testing? Works on all 3 of my machines. If it doesn’t work, can you try and download the Microsoft distributable please?

I downloaded and installed the latest visual c. Will test your previous and new version and get back to you. Thanks for helping me getting this done

Ad