Media Player goes with delay

I want to put “cue guides” in my songs indicating with a voice in the background saying “chorus enters”, “guitar solo enters”, “verse enters”, “4,3,2,1”, etc…

I don’t know if I’m doing it right but for each audio I use a different media player (If it can be done in another more effective way, please tell me).

On the other hand, when I make a binding and say that, for example, mediaplayer1 is launched in measure 2, it seems to be with some delay. It feels like sometimes it goes well and other times it’s a bit slow.
Any idea why it could be?

The audio files are .mp3 of 50 KB at most.

Thank you

Hi, are you using Cantabile’s internal metronome/transport or a midi file? I use cue tracks a lot in one band that uses backing tracks, but they’re all mp3 tracks. I know some folks here use midi files, but I found that going all audio is extremely easy and I’ve yet to have a problem, either in programming or gigging. And the cpu load is pretty low

I haven’t run across your specific issue, but a few things to double check: Check your Master/Slave Sync mode on the media file. Check for other bindings that may be conflicting, even inside racks. Try building a new songs from scratch with just a couple racks and your media players… I’ve sometimes found that when using old songs as a template for new ones, things somehow get corrupted or don’t work as expected, sometimes because of old bindings that are still present.

Wish I could be more helpful.

Hello, I return to this topic!

-I use the internal cantabile metronome with a custom click sound.

-As for Master/Slave, I don’t know exactly what it’s for, but I haven’t touched anything. I simply create a MediaPlayer and leave everything as default.

-I have noticed that for the recorded sequences of songs they are also somewhat delayed.
The way I work is the following:
*I open Cubase and set the metronome to the same bpm that I have in Cantabile.
*I have the same custom sound for clicks in Cubase as in Cantabile.
*I record my sequence in Cubase on time and perfectly timed.
*I export the entire track in .mp3 from the beginning and as far as I am interested, for example measure 50.
*I load that mp3 track into MediaPlayer in Cantabile. And I make a Binding so that when the metronome is executed the MediaPlayer track is executed.

The conclusion I notice is that it is a little late, it is not exactly the same as in Cubase.

How could I solve this? Is there any other way to do it better or more accurately?

Thank you

Due to the way bindings are implemented and executed, there will always be a delay when a media player is launched this way - it could be up to two audio cycles.

If you just want to start a media player precisely with the metronome, try setting the metronome as the master transport:

and the media player as realtime slave:

If you need something more complex or different to this, please let me know.


Thanks Brad…I’m going to try this weekend to see if I can fix the delay.

Thank you


Now it works correctly. I understand that this is the correct way to do it, right?

If I wanted to launch a sequence from measure 40 for example?

You don’t recommend launching the media player there, but rather playing it from the first measure even if for 40 measures it doesn’t sound at all, is that correct?

Thank you