Mapping NanoKontrol sliders to MIDI controllers


#1

Guys,

The end result I’m after is when I move a NanoKontrol2 slider it affects the MOD input of a soft synth.

I’m trying to create a route from the NanoKontrol2 to the soft synth with the controller mapping, but when I put the Filter into LEARN MODE I’m not seeing any events.

When I move the slider, I see MIDI activity coming from the NanoKontrol and mapped to my virtual NanoKontrol rack.

Any ideas?


#2

Alright, I was able to convince the MIDI monitor to open on the routing.

Looks like Slider 2 is mapped to Modulation.

Now to focus on the other end.


#3

You mean the learn mode inside your plugin - correct?

Sometimes it is easier to use Cantabile’s bindings to control parameters of your synth instead of using their MIDI mapping feature: once you’ve found the right MIDI source source (apparently for you, it is NanoKontrol MIDI port, Controller 1), you can choose the destination directly in the Bindings page:

You’ll have to select your soft synth plugin as destination, and then select the correct parameter from the numbered list - you’ll have to scroll a bit, and maybe also experiment, which parameter is which, but you’ll get there…

Cheers,

Torsten


#4

Hmmmm . . . Initially I was playing with Cantibile MIDI filtering page and wasn’t seeing any events.

Then I went to the Bindings page, where I was able to find the event (Fader 2 is is MOD), which accomplished what I was after.

The wild card is I flat out forgot that the Nano has different modes. I need make sure it’s in CC mode and try it again.


#5

Yep, I definitely had both problems, NanoKontrol2 was in a weird mode.

Factory reset then put mode to CC and it behaves the way I expect.

And using the Bindings page in Cantabile was the correct approach, rather than trying the plug-ins or the filtering page.