Leslie effects VST not recording in DAW


#1

This is a little outside the scope of what’s usually discussed in the Cantabile forum, but I’ll ask anyway. In my DAW (Mixcraft), I have a track set up with Blue3. I’ve applied the Amplitube Leslie VST to that track and tied the speed to my damper pedal. So far so good. While I’m recording the track, I can press and release the damper pedal and hear the Leslie change from fast to slow, slow to fast. However, when I listen to the track after recording, there is no change in Leslie speed. I’ve tried this with other Organ/Leslie VST combinations as well (e.g. VB3 and Spin)- same result. I tried a different type of VST effect, e.g., flanger or chorus, and that DOES record correctly.

Any idea why I’m not getting an effects sound on the recording? By the way, I don’t think it’s an issue specific to Mixcraft.


#2

Maybe CC64 is being filtered for some reason?


#3

In that case, why would it work at all? Everthing seems ok until I listen to the recording.


#4

Because at least in Sonar, controllers would still be working in real time as you play but it could be configured to not actually record them. Not something that would generally happen without being set up that way, but it’s worth checking.


#5

hmmm. The effect is set to active. Not sure how else I would ensure it’s set to record. As I mentioned, other non-leslie effect plugins seem to record fine.


#6

That’s deeply weird. I have no ideas… gotta think on it! If you record, say, a piano does it work normally? It could be an issue with passing the controller on to an additional VST- Sonar really has serious issues setting that up properly. Maybe live it controls both but on playback it only controls Blue3. Is Blue3 responding to the pedal on playback?


#7

If you’re asking does the spin component which is integrated in Blue3 record correctly, the answer is yes.


#8

Then it’s related somehow to passing that controller through to IK on playback. How, I don’t know, no experience with that DAW at all.


#9

Thanks, I appreciate your help. I haven’t tried another DAW, although at a basic level I don’t think there’s much difference between Mixcraft and some other popular DAWs. I have Reaper, perhaps I’ll try that one. It’s really not a big deal, more of an annoyance.


#10

One thing that is different about these Leslie effect VSTs, is that they have to be included in the Input Port section in order to work properly…So IF I understand correctly, you have to explicitly specify a path from the midi controller (keyboard) to the effect.


#11

You could try putting the Leslie as an insert in a separate bus and route the organ to it. Don’t understand why channel insert not working?


#12

That is correct. How else would it get a MIDI signal to it? That is the way I have to do it in my live setup.


#13

Thanks to a response on the Mixcraft forum, I have an answer. It has to do with setting up and “arming” EFFECTS AUTOMATION for recording. Once that’s done both the organ vst and leslie effect changes will be recorded.


#14

Hi @LeesKeys ,

You have to arm the automation and select what to recordAutomation.


#15

In Sonar, you actually need to enable the recording of ‘automation’ via MIDI controllers. Also, you can load the MIDI (Piano Roll) view, and add the sustain (64) controller to the view. If you see changes in that lane, then no explanation… (?). If you do not see activity in the lane, then specifically choose to record automation. This is a strange issue since you can likely record the sustain pedal while playing a standard keyboard (piano) instrument. I used to have the same problem with another Leslie VST in Sonar, and indeed, it was not recording the controller movements. I solved with automation recording.