Korg NanoPad disconnect Issues


#1

I have had and continue to have major issues with NanoPad somehow disconnecting itself almost every time I restart Cantabile. This is getting irritating and tiresome, especially when trying to perform live!

Is there anyone else experiencing these odd disconnects or issues with Korg NanoPad? Sometimes my NanoKontrol does it, but I just have to unplug it from the hub and plug into a different port and reconnect.

NanoPad however, not so easily resolved.

Can anyone help? Or point me in a direction. I’m ready to give up. I love CP3, but this is creating major issues with performance.


#2

Hi Christian,

I don’t own a NanoPad, so without being present when it disconnects, all I can offer is change USB cable (if that is how you are connecting). Or install newest Nano driver. Are you using a powered hub? It will make a difference. Did you change your computer settings to disregard USB timeouts? Is there a setting in Nano to time out after a period of no use? I will chime back in if another idea arises. It is 1AM here, so my ideas are not flowing very well. :grin:

Corky


#3

A bit of a wild card question, but have you followed “Glitch Free” to ensure that the USB ports do not go into hibernate mode? A bit of a stab in the dark, but worth checking.


#4

Hi !

I had korg nanoKontrol with similar issues. Tried to update drivers, change usb plugs, reinstalled some other drivers etc but nothing helps. Then i just bought behringer xtouch mini and i’m happy now :slight_smile:

So there maybe something wrong in this korg (hardware/software).

kind regards


#5

I’ve done all of the above, most recently all new USB cables. I’ll hero troubleshooting! Thanks Corky!


#6

Good idea Derek! I’ll look through the Glitch Free Guide again. It’s been awhile. I’m also looking at switching to a new laptop (nervous). So that will be a great refresher.


#7

You may be on to something. I basically need a nice mixer type control, and something to trigger samples, intros, fills etc. I’ll look at the Behringer.


#8

Older* versions of Windows had problems if you didn’t plug MIDI devices in to the same ports every time. The solution was to go into Window Device manager, set it to display hidden devices, and delete the “ghost devices”.

*I say older versions, but I still do this on the latest version of Win 10. Always plug in to the same USB ports with the same USB hubs, same cables, etc. And if you must use a USB hub, use a powered one.


#9

I didn’t know that one Richard, Thanks!!

Dave


#10

AlthoughI use two powered hubs, and I have designated specific ports for each device (3 keyboard controllers, a foot controller, NanoKontrol, & NanoPad) the issue still happens frequently. However, I haven’t heard of this windows hack before either!
Thanks, I’ll give it a try!


#11

I own a Korg NanoKey (not NanoKontrol) which had similar connection issues. Korg support did not reply any forum posts, but released new drivers (without large announcement) some weeks ago which fixed the problems for me. (The latest USB drivers are dated 2020-01-31).

Concerning USB power: After updating to Windows 10 Build 1909, my Lexicon Lambda turned off after a minute of inactivity. There were no options in the driver settings to configure power saving behaviour. So I had to sell it.

BTW: To see hidden devices in the device manager, don’t forget to make them visible first (via View Menu).
Alternatively you can use the Korg Driver Uninstaller. It’s located in “Program Files (x86)\Korg…” and called “UnInstDrv64.exe”.