Kontakt doubled notes

Something I’ve noticed with Kontakt - if I hit a note, and hold the sustain pedal, then hit the note a few more times, the volume accumulates, getting louder. I’m assuming the same note is being assigned to other voices, playing simultaneously, instead of the more usual MIDI behaviour where the same note played will go to the original voice, and retrigger it.

Are other people seeing this? Any idea how I can disable it and revert to the more normal behaviour?


1 Like

Hey Neil,

Don’t have a solution, but I just tried it here with the standard “Grand Piano.nki” that ships with Kontakt and it doesn’t seem to be doing that.


Hi Neil

Not experiencing it here. What version of C3 and Kontakt are you using?


I’ve certainly never noticed that… I wonder if it would be worth it to blast Kontakt and do a fresh install and get it back to the defaults. You would probably have to be very thorough, cleaning any registry settings out and really cleaning up. Just a thought.

Upon further investigation it seems to be just the sample sets I’ve made myself - the factory presets all behave as expected. Which suggests it’s not a version or installation issue, but something different about my own sample presets in comparison to the factory ones. I shall investigate further…

1 Like

I would say “Aha!” but you can’t make a post under 20 characters but now I’ve said all that too so I can. Aha.


I take it back…no they don’t! It’s apparent on some of the strings factory patches, and you can see the “Voices” indicator in the Kontakt UI going up. So it’s clearly a deliberate thing, to play any repeated notes under sustain on a new voice, while maintaining the original, probably to make certain patches sound smoother.

But if you’re playing a layered piano + pad, and doing arpeggiated chords with sustain, the pad just gets louder and louder until you release sustain, which is not good.

Just thought someone here might be aware of a way to disable it (I trust the knowledge/expertise of the forum members here far more than any NI forum!).


1 Like

Just out of curiosity, what libs are doing that??

The “Violon Solo” patch in the factory library, Orchestral → VSL Strings is a fairly good example, but it seems to be noticeable on most sounds that sustain evenly, so you can hear the increase in volume.

It’s clearly by design - you can see the “voices” indicator increasing with each sustained keypress on that single note. It would just be nice to be able to find a way to disable it, so any given note can only have single polyphony.


What would be great is to have a midi script that ignores repeated notes while the sustain pedal is down. I know that some scripts inside LA Scoring Strings do that. But I’m not a programmer and have no idea how to replicate that feature for other Kontakt patches. I truly wish I knew how to program. I think I may start a thread on it to see if anyone hear has any ideas.

But yes, I deal with this exact same problem all the time when layering piano with pads or strings.