Kontakt cpu usage

I have a kontakt instrument that is spiking the cpu in cantabile. I do not have the issue with other kontakt instruments. I have set the voices in kontakt to 8 and purged the samples to see if that helps.

Here is the information
The Steel Electric from indiginus

Kontakt Full v6
Latest Cantabile build
Windows 10. i7 6 cores 32mb memory.

I have tried increasing the audio interface sample rate and that seems to help a little. Just looking for ideas.

Not posting with solution but just figured I’d mention that Orange Tree has a great lap steel for Kontakt v6

EDIT - just listened to the sample for Indiginus - sounds great!

1 Like

Could be useful a screenshot of the Load & Info side-panel to permit us a starting point. I’ll try out the Orange Tree Nylon Guitar library, I know it’s not the same instrument, who knows, might be a little meaningful test.

Edit: here is Nylon Guitar playing its own demo midi file. Peak is 13%


A little OT, but I have Orange Tree Lap Steel which does tend to be CPU heavy and not very natural. I have been using Wavelore Pedal Steel for several years…very intuitive and low CPU.

What sample rate number are you using?

Sample rate is 44,100. I upped the buffer size and that seems to help.

My buffer size is set to 512 without a latency problem. But, that is just me, and my rig. Even amp sims work just fine at that setting. Experiment with it…there are also settings in Cantabile “options” you can try.
I saw your thread at KVR, and maybe you should try to block the “call home” settings on your firewall. It is true that some plugins in Kontakt will try to call home without asking, which spikes the CPU as they continuously keep trying (the same way Windows updates will do if you don’t block them). Your output processing suggests that.
You could also run the plug while internet is on, and let it resolve it’self…something I never do, but it may need to call home to stop it.
Hope this helps you.




@Corky I changed the buffer to 512 that seems to fix the issue.

Cool! Glad you got it going. You can reduce the number if needed, but 512 works fine for me. Experiment with it, unless you are satisfied with that setting.