Keyboard split bug?

I am trying to use the keyboard split filter but I am getting strange (to me) results. Here’s a screen grab

The plug in has one sound on channel 1 and another on 2. I want to control this with a simple keyboard split at C4. Above C4, all is as expected, but below C4 the filter is sending both channels. I tried doing the same thing with 2 keyboard range filters but got similar results. I also need to transpose the lower split up an octave and the upper split down an octave, but when I add that I’m getting both the original note and the transposed note. Thoughts?

The midi filter looks correct, the MIDI received looks wrong. So I tried it here and it looks fine:

Most likely you’ve got other routes or other MIDI filters somewhere in the chain affecting things.

  • Where are you placing the MIDI filter (route, plugin, environment port)?
  • Do you have multiple routes feeding the plugin?
  • Do you have other MIDI filters anywhere in the chain?


Hi Brad.

It has just one feed (Komplete Kontrol S61). The upper midi monitor shows this sending only on channel 1. The filter is placed on the route. I believe the lower midi monitor is ahowing the input to the plug in. I don"t see how another filter would show an effect between these two points. Unless I have somehow managed to attach two filters to one route.

However. I had the same thought and I believe I checked all other potential places where another filter might be applied and found none. I also checked that transposes and key ranges were cleared. Is there a way to check this stuff besides right clicking everywhere there might be a filter? Are the files human readable or binary?

Thanks again for your quick response.

FWIW, I tried the pre and post settings on both of those midi monitors. No difference.

I am successfully using key range filters to split the keyboard between two differnt plug ins. This is the only place so far where I am sending both sides of the split to the same plug in. But midi channel should take care of that.

I may try doing both sides split to some other single plug in. But right now it’s past my bedtime

Regardless of the actual name extension, all Cantabile’s configuration and settings files are JSON plain text.

1 Like

To confirm: are you saying that if you bring up the MIDI monitor for the route with the MIDI filter then the pre-filter monitor shows a single event incoming, but the post filter is showing multiple events outgoing?

(Note: in your original screen shot you’re showing the MIDI Monitor for the plugin not the route)

Note you could set this up with MIDI route key ranges instead of key split MIDI filter. Just create two routes, each with a range and direct both to the same plugin, one with a channel change… (but I’m curious to understand what’s happening here)

Hi Brad,

I’m probably misunderstanding something. I am monitoring the output of the keyboard (all channel 1) and the input to the plug in (channel 1 and 2 below the split). What’s in between except the route and it’s midi filter? I will try monitoring the route when I get home. They made me come into the office today. Ugh!

I already tried using two key ranges to the same plug-in (Miroslav Philharmonic) but the result was the same as the split. Not surprising, I suppose. I know I am in another thread regarding Miroslav, but this all seems to be happening before it even gets to the plugin.

As always, thanks for the support.

Thanks cpaolo. I’m not familiar with JSON but I will see if I can make any sense of it.

@raydo, you can view your Cantabile song or rack settings because they are stored in viewable text based file. I’ve been using Notepad ++, a free text viewer/editor that can highlight the text to make it easier to view (in the file menu choose Language > “J” > JSON. Take a look at you file, you’ll find it interesting. Don’t save it in Notepad++ unless you know what you’re doing and have made a backup first :grinning:

Thanks dsteinschneider!

I’m fairly new to this group. Everyone has been extremely helpful.

I use ultraedit every day for C++ and occasional XML editing. I just checked and it supports JSON as well. Down the rabbit hole…

You’re well positioned for this rabbit hole :grinning:, welcome to the forum!

In between is:

  • The MIDI filters on the MIDI input port (in Options -> MIDI Ports -> double click port -> MIDI Filters)
  • One or more routes, each with per-route MIDI route settings and per-route MIDI filters (click the MIDI filter button in the route or plugin slot).
  • The plugin’s MIDI filter at its input.

For completeness, bindings can also intercept MIDI in that chain - but they’ll only really steal or allow the MIDI to continue along the chain.

Note too that you can show a MIDI monitor for most points along that chain:

  • right click on the port in the monitor panel choose MIDI monitor
  • right click on the MIDI route choose MIDI monitor
  • right click on the plugin and choose MIDI monitor.

And, in some cases you can choose different pre and post views in the monitor panel.

The MIDI monitors should give you enough to trace through where the extra events are coming from.


1 Like

Hi Brad. Thanks again for trying to help me out.

You are correct. The midi filter in the route is working correctly. But something is going on between there and the input to the rack

Going through your list:
There are no midi filters on “main keyboard”. The route filter is getting the expected input (all notes ch1).

You can see that there is a single route from main keyboard to Philharmonik. The filter in the route is doing what is expected.

There are no midi filters on the plug-in input, yet the data at the input is different than the data from the route.

I have done almost nothing with bindings so far. One midi volume pedal to an amplifier gain knob is the extent of it. No relation to main keyboard or Philharmonik.


Hi brad,

I have probably destroyed any chance of figuring out what happened, but I deleted the Philharmonik (embedded) Rack and created a new linked rack. All appears to be working as expected


Hrm… are you sure there was only one route from Main Keyboard to Philharmonik?

It’s really hard to tell when you’re in routing diagram mode since the lines will exactly overlap. Switch to table view (View menu -> Routing Table) to double check this.

Given that you deleted and then re-added the plugin and it fixed it, I’m guessing that’s what happened since deleting the plugin would have deleted both routes. Re-adding the plugin would have only added one.

pretty sure there was just one. Before punting, I deleted them all and reconnected just one. But the only other connection was the on-screen keyboard. I wasn’t pressing that so I don’t see how it could affect anything.

I don’t recall if I have the on-screen set up to display incoming notes. Could there be a midi loop with that setting?