It's probably impossible, but how do you route audio input ONLY to a plugin, not the whole rack?

I’m using Cantabile 2 (hey if it ain’t broke don’t fix it), and in addition to midi vsti’s I’m running S gear for guitar as a plugin, in it’s own rack. However, I’m still hearing the dry, clean guitar straight from the input, mixed in with the S Gear. And when you mute S Gear, ti’s there front and center. I’ve tried very imaginable routing set up, in the audio engine, in master bus and in Channels, no luck. I don’t think it’s possible to get that muted using Cantabile… any ideas?

BTW, when I run S Gear standalone this doesn’t occur at all, I only get the “wet” S Gear output, so it’s not the plugin. I’ve had this issue for a while now and I sort of gave up on it, but lately it’s been bugging me more and more. And yes, I have the plugin as loud as it can be to help overpower it, but I’m doing some new, softer stuff lately and it really colors … er, make that dis-colors… my tone. Help!

And before someone says it first, let me guess… this is probably a feature in 3? :slight_smile: Thanks!

What are you using for an audio input?

Sorry, should have included that too. Scarlett 2i4. (It has a input vs playback monitoring mix and I have that set to full “playback” mode, so all that’s output at ch 1/2 is the processed signal). Any ideas? Thanks man!

BTW the most obvious function should be the Dry and wet volume control, which, of course, is set to 0 dry. I’ve noticed that on many plugins the Dry does nothing at all, which is clearly a function of the plugin itself.

I mainly use Scarlett 18i8 as my audio interface. I haven’t used C2 in a few years, so my knowledge of it is limited, but I know it has an audio setup in settings. Just for starters, make sure you select the Focusrite driver in your audio settings. Make sure audio input is enabled by selecting the input check box in the master levels panel. I am using S-Gear with Focusrite and C3 with ease. You should be able to do the same in C2 as well. If this doesn’t work, check your outputs. BTW, what is your output setup in Focusrite? One other thing I was pondering is the direct monitoring in Scarlett. You may want to try turning it off, as it will not allow the processed audio to be heard, which would give you the “dry guitar”. Direct monitoring is used to hear your input signal with 0 latency and goes directly from input to output.

Yeah, I’ve done all that. AFAIK the 2i4 doesn’t have any software associated directly with it like some soundcards, so I don’t think you can turn it off. However as mentioned earlier I have it all the way to Playback, with no input signal. The output of the 2i4 is set in Cantabile as Ch 1&2, Input is 2 (my guitar input…already tried 1, no change). I think it’s a function of how Cantabile handles an audio input in the rack, at least with this plugin… once I enable the audio input for a rack by clicking the mic icon, that audio is passing automatically to the output of the rack, regardless of the plugins. At least that’s how mine’s working. I even tried using a partial send to SG in another rack, same issue. I’m definitely stumped… hopefully Brad will chime in…

I’m thinking more about how on many plugins the Dry level doesn’t work at all. And that’s definitely the case with S Gear. Maybe there’s something with Cantabile that doesn’t fully ‘recognize’ SG, so the Dry function is disabled, and defaults to full level. IDK, I’m grasping at straws here… it’s pretty frustrating.

OK, I just figured it out and I feel sheepishly stupid. The solution is close to my guess on the last post. In case it helps someone else I’ll eat some crow, bare my foibles and explain what happened…

I started completely from scratch, as if I was just starting to use Cantabile. I did a step by step analysis, checking every single function, routing, or setting I could think of. I even pulled the 2i4 and tested that on another computer, because for a while there I was thinking it had to be that. And here’s what I just learned… when you bypass or mute or suspend a plugin (when it’s the only plugin in the rack), in fact C2 does default to the Dry signal, with no way to mute it. By the same token, if you have a rack without any plugins, the same thing occurs. (At least that’s how mine’s working.)

But if the plugin is enabled, then the Dry slider works fine (as it should). So each time I muted the plugin, I’d hear the dry, and came to the mistaken conclusion that the dry was also there when the plug was enabled too. I didn’t know that C2 would default and re-route to 100% dry. ( :blush: In my defense that’s somewhat unusual DAW or hardware behavior… usually when you mute the only/last item in the signal path, it stays muted! And when a plug is muted, automatically re-routing a signal path that hasn’t been selected by the user is sort of funky, IMHO). I’d always been trained to use mutes when troubleshooting to eliminate any other possible errors in faders or signal routing with sends, etc… and I’ve worked with some of the best engineers in the business.

So I moved the dry slider with SG enabled, and instantly realized that the “dry” I was hearing before was not really the dry… the dry signal faded in an out with the fader as it should. Hmmm. That’s odd, then why does it sound like a dry signal (my main issue was I was hearing string/pick plucks that were most prominent in dry). I then instantly realized I’d raised my pickups a few weeks earlier, played a bunch of driven/lead and crunch patches, and finished the setup. Then when I went to super clean tones the other day, what I was REALLY hearing was the difference in pickup height.

You’d think after 20 years working with DAWs, Sonar, Garageband, VSTHost, Studio One, every major mixer brand and a million other pro audio hardware and software, and 30 years in pro audio, I’d avoid an issue like this one. Well, at least I learned something. I’m not knocking Cantabile, but this isn’t the first time I’ve come across relatively unusual software architecture that isn’t documented in the C2 manual (at least I couldn’t find anything on this). On the other hand, it’s a very complex subject so that’s going to happen. Regardless, for the $ it’s a pretty darn good program.

Thanks for your help!


I don’t know that I was much help, but am glad you solved it. Now…crankit up!!