Issue with Korg USB MIDI and Cantabile

Tags: #<Tag:0x00007f977dd4c418> #<Tag:0x00007f977dd4c350>

With my Korg devices, the keyboard must be booted before Cantabile or it isn’t detected. Not a huge issue, but if there’s a problem mid gig, that’s couple of minutes of dead air waiting to reboot and reload about 100 plugins. This was an issue in C3 and C4 with both my SV-2 and Kross 2.

The terrible Korg USB Midi driver is certainly the culprit. To be fair, it is a Windows 10 driver running in Windows 11, but it had all the same issues in 10. Not the least of which being that any keyboard running it has to be one of the first 10 midi devices registered, or it won’t work at all. Korg should be ashamed of themselves - no updates to a driver with well known issues for a year and still no actual Windows 11 driver TWO YEARS after release. Had I known, I could’ve spent those two years learning how to code and fixed it myself. But I digress.

Has anyone figured out how to finagle it without rebooting everything? Stopping/Starting the engine and switching to other audio drivers doesn’t work to jump start it. Other usb midi devices have no issues connecting/reconnecting.

If the Midi-to-USB or USB-DAC driver(s) does not connect in Cantabile and show a GREEN Audio Engine and have midi input when Cantabile is started, I can usually get Audio running by stopping/starting the Cantabile Audio Engine. Click on RED circle (it’s green below) and stop/start.


You stated you’d stopped/started the audio engine and it didn’t help…

OR for a midi device not working,

Go into Tools/Options/MIDI Ports and make sure Windows has assigned the actual MIDI/USB input to the Cantabile Input. Below, the USB Axiom 61 is “disconnected” and you may have another “Axiom 61” in the list that is connected. Check the box by the “Connected device” to port the connected device to the Cantabile MIDI Name. My system typically has more than one ASSIGNMENT for the same NAME.


Sometimes, I have to unplug/replug the USB device and repeat the steps. Rarely does Cantabile have to be restarted in my case.

This will start a Sh**t storm on this Forum, but if the Korg USB drivers are that “terrible,” switch to actual MIDI (5-pin DIN) and get a modern, rock-steady MIDI-2-USB converter. Those Korg keyboards look very nice and I’m surprised it would have a substandard driver. You might have other windows issues causing problems, too. Many users on this forum have noted Windows/USB/Cantabile sometimes randomly connects differently each time the system is set up. Windows “rearranges” as it sees fit and not what Cantabile is expecting from the last Cantabile Load.

Did you try using another host (or DAW)?

I’m definitely sure this is not a Cantabile issue. It’s a Windows conflict with Korg device drivers.

1 Like

Agree totally. Sometimes I’ll use Bome Send SX to see if the USB/MIDI is connected to PC, too.

Yes - that’s what I was referring to.

Yup. I only have issues with that if something gets physically plugged into a different port, but I essentially have alias set up for all the things in all the ports so it doesn’t matter.

Right - it’s not a problem for anything else (Nektar and M-Audio controllers, Midi Expression Pedal, Boss VE-500, Volt interface, all through various USB ports and hubs). It’s only the Korgs that don’t want to reconnect.

You’re not wrong. I just don’t want to have to add another device and two more cables that will have to be mounted and secured somewhere when a USB cable should be enough. I know I know, if it’s that big a deal, there’s a solution. It’s just…irksome. I shouldn’t have to solve a software problem with hardware.

The driver probably works well enough for the 99% of users who aren’t running complex rigs. The fact that it has to be one of the first 10 midi devices to work reeks of some Y2K-esque code recycling. Software written for limitations of older hardware that no longer exist. Apparently, they’d rather give you an uninstall tool to clear out the other devices than fix whatever weird port assignment issue is causing it. I dunno. Maybe it was like one dude who wrote the core driver but has been gone for years, or they lost the source code, and now the new guys don’t know how it works so the best they can do slap some duck tape on it and re-release it.

Once it’s up and running, it’s usually fine. But once in a while a cable gets knocked loose, or I forget to turn the keyboard on first, and I’m suddenly holding up the sound check, watching the loading bar crawl along, and have to endure one more “this wouldn’t happen if you had a Mac with Mainstage.” :roll_eyes:

HA!HA!HA! Don’t believe that crap! I’ve played with a keyboardist who insisted on getting Mainstage and a Mac when one of his hardware synths died and EVERY PRACTICE was a USB Mind-Fu(|{!

I haven’t tried purposefully disconnecting and reconnecting in another DAW. Could be helpful to Brad if he wanted to take a crack at a workaround, but it’s really an edge case so probably not worth his time.

1000% it’s caused by the Korg driver. But I don’t think it’s entirely a Windows issue - I think the port is getting stuck open in Cantabile because:

  1. Restarting Cantabile fixes it
  2. Cantabile thinks the device is still connected, so something isn’t passing that info along
  3. When it reboots/reconnects, it isn’t being installed as a new device in Windows, so there’s no new assignment to switch it to. Windows recognizes it at the original address.

Oh believe me. I know that, you know that, but even though the last time we did a recording session his Mac crashed every 10 minutes (they fixed that, you know), they do not know that. :laughing:
But oh man, every time something goes wrong, “it’s them Windows drivers again.”

No to mention I don’t think Mainstage can actually do the dumb routing that I do. I don’t like to push buttons mid-song, so I end up with a lot of key zones and modwheel layering zones. I’m no Benmont Tench, but by gum I can use Cantabile to give me 3 octave chord stacks from the mono riff I’m playing one handed while it sends sustained block chords to my vocal harmonizer and I use the mod wheel to sweep a filter, crank a drive setting, throw in that 4th octave, and add in a sequencer.
“Just put it on a track.” Pttthhhhpt. I am the track.

1 Like


if you think it’s a Cantabile bug, report it to Brad. Or, as @easteelreath said, switch to a MIDI DIN interface, avoiding USB.