Is Cantabile “capturing” the ASIO driver?


#1

Hi, i use my firewire Edirol FA-66 audio interface as primary audio playback and record device in Win 7.
With other daw i use (Cubase Pro 10) i can use the FA66 with ASIO AND i can also listen to other sound sources like YT, VLS, mp3 players etc.
But when i use Cantabile (using FA66 ASIO driver in the setting) when i quit the progz i have no more audio from the other sources… until i restart my pc.
Seems like Cantabile captured the audio interface for his own exclusive use and won’t release even after quitted!
Any ideas about?
tnx


#2

Hi. Not sure if it helps, but I used to see this problem in Cantabile 2 if I plugged my Focusrite Diamond USB into a USB 3 port. It was fine in a USB2 port.

Most probably not related, but thought I’d mention it in case it generates any ideas in the community.


#3

Tnx Derek, yep i see… but i’m using a firewire audio interface here!


#4

I know :slight_smile: but thought I’d mention the experience in case it’s a problem with FireWire chipsets/drivers doing a similar thing? Dunno.


#5

To use YT etc I use an old laptop that connects into stereo inputs on the audio interface of my Cantabile machine. That way even though C3 has exclusive use of my ASIO driver I can still play along with YT etc.

I use AudioSwitcher after closing C3 to force Windows sound to pick the right source:

https://audioswit.ch/er?utm_source=client&utm_medium=direct&utm_campaign=client_1_8_0_142


#6

TNX I’ll give it a try… but don’t seems it “force” anything… seems to be only a GUI that uses the API of the sound source switcher of Windows. Is faster and easyer but don’t force nothing i think.
In my case the prob is that mye audio interface seems to be captured by Cantabile even when i close the program (but the right playback device is already correctly selected in windows).


#7

You’re right - audio switcher is a just a system tray shortcut to the windows controls for the sound source. I had a situation where after running Cantabile it would stay on the USB Audio interface and I used Audio-Switcher to “force” it back to the motherboard audio - not the best choice of words. Not sure why you can’t go to another source after using the audio interface. I guess it has something to do with firewire


#8

I try to clarify my situation (my crap english is not helping me in this!).
In Windows the playback device selected is my firewire audio interface.
So everything i play in Windows (Winamp, VLC, Youtube, etc) goes through that playback device (think is using the WDM driver)
In Cantabile i selected tha same audio interface (using the ASIO driver).
When i QUIT Cantabile… i have no audio from Windows (from Winamp, VLC, Youtube, etc), but the playback device is STILL my firewire audio interface.
Before installing audio-switcher (it’s a good utility anyway) i’ve tryed to switch forth and back the playback device… but no audio! The only way is to restart Windows!
So, if the only thing that audio-switcher do is to switch the playback device… don’t seem to be the solution.


#9

Hi Antonio,

I think @brad should take a look at this problem so I put a shout out to him here to let him know.

Dave


#10

Your english is very clear, no worries on that :grinning:

Unfortunately I think this problem might be hard to solve. Most likely there aren’t many Cantabile users on Firewire so there isn’t much experience here with it.


#11

All Cantabile is doing here is loading, starting, stopped and unloading the ASIO driver as any other application would. As far as I’m aware there’s nothing in the ASIO API spec to indicate if the driver should run in exclusive or shared mode.

Some drivers however do have this option either in the options window shown when clicking “Control Panel” in Cantabile’s Options -> Audio Engine page. Other drivers have this option in the Windows Control Panel somewhere. ie: check the docs for your sound card to see if it has this option and how to set it.

Also note that some ASIO drivers store there settings separately for different host applications which might explain why it’s behaving differently in Cantabile to other hosts.

As for not being able to use other programs after running Cantabile, I suspect this is related to the driver too however could you please confirm something for me: does this happen if you just open and then close Cantabile? Or, does it only happen if you start Cantabile and then go into Options -> Audio Engine and then close Cantabile.

Brad


#12

Tnx @dave_dore and tnx @brad
So some answers:

  1. the audio interface driver interface don’t have any settings about the exclusive or shared use; but with other daw (Cubase) i can play the tracks AND some external program (Youtube via browser i.e.) at the same time. I think this is because the daw is using the ASIO driver of the audio interface while Windows is using the WDM (or MME) driver of the same audio interface, so it’s something like ther are two different “devices”.
  2. Cubase (like i think other software daws) have a setting that sayz “release the ASIO driver when minimized” or something like that… that means that if you leave the daw windows (while the daw is running) and go to another window of another program that use the ASIO driver too you can play. I think this is something for those audio interface that are “ASIO exclusive” and not “ASIO shared” so Cubase release the ASIO driver when you leave his interface/windows.
  3. as for you last question if i well remember the ASIO driver of my audio interface was selected in a different previous session inside the audio engine setting of Cantabile. So the prob kicked out in another session where i only opened Cantabile, loaded some plugins (Arturia B3 hammond), setted 2 different midi keyboards for the upper and the lower manual of the hammond and after some playing i closed Cantabile. After that no audio from the other programs until i restarted Windows.
    Anyway… i will try some different sequence of actions so i’ll be more precise about that.
    Tnx again ppl!

#13

I am using a Focusrite Scarlett 18i20 and at first had a problem with Cantabile and Jriver running at the same time. It turned out to be a setting in Windows buried in the older control panel style audio properties interface.

image

By unchecking the exclusive mode boxes the problem cleared.


#14

I think this is the answer to your question. Cantabile doesn’t have this option because it doesn’t make sense for live performance software. If you want to leave Cantabile running while you use another audio application, the Power button in the top right corner can be used to shutdown Cantabile’s audio engine and release the ASIO driver.


#15

Nope @brad … the prob here is that when i QUIT (close forevah!) Cantabile i have no more audio from other Windows source (YT, browser etc)!
AND the other Wiondows source don’t use the ASIO deiver but the WDM driver!


#16

I can’t see how this is anything but a problem with the ASIO driver - unless there’s some weird condition in which Cantabile isn’t releasing the driver, but that would cause issues with other drivers too so I doubt it. To check could you please do this:

  1. Make sure Cantabile is configured to use the audio driver in question.
  2. Reboot your machine
  3. Start Cantabile
  4. From the Tools menu, choose Open Settings Folder.
  5. Close Cantabile

(don’t do anything else between steps 3 and 5)

From the folder opened in step 4, send me the files log.txt, log-previous.txt and settings.json

In the meantime, could you try using ASIO4ALL and let me know if this exhibits the same behaviour.

Brad