Inputs randomly mute

Hey all, I hope you can help me with this issue. Basically when any input device is continuously active, all inputs randomly mute for a few seconds.

I cant find a pattern as to why it happens, I played with audio engine settings, different sample rates, different buffer sizes, problem continues.

I use Cantabile Lite Cantabile 4 Build 4174, 64-bit version + ASIO4ALL

Not sure which logs to look at, below is a video of the behavior. Please let me know if you need any more info.

Any suggestions as to how to diagnose this issue?

Thank you!

Hi @Acito and welcome to the forum!

At first sight, you are running with a quite heavy Time Load. It is not safe to run close to 100 %.

As you can read down below, a 100% Time Load means that Cantabile needs a time equal to the length of the audio buffer to prepare a new audio buffer (that is: you are on the verge of audio glitches!).

Understanding Cantabile's Performance Metrics - Cantabile - Software for Performing Musicians.

However, the behaviour you are experiencing is not, IMO, what you usually get when the Time Load exceeds 100%. You do not have audio glitches. Your audio simply disappears for a while. I have noticed that you have set Cantabile as “Double buffered”. Does the problem happen also when “Single Buffered”?

If I understand correctly, you are using Cantabile to process external audio (e.g. a guitar). If this is the case, audio interruptions could be also due to the audio interface you are using. The audio could be interrupted upstream with respect to Cantabile. To check if the problem happens also for internal audio, you could load some kind of VST instrument with an arpeggiator or some other means to produce audio continuously (unfortunately you can’t use a media player since they are not available in Lite) and test if the audio interruption also involves this plugin. In this last case, the problem would happen in Cantabile or downstream from Cantabile.

Finally, if you want to have a look at the logfile, just follow this instructions:

Basically, when you run Cantabile and select the menu Tools->Open Setting Folder
it will take you to a folder where you will find the log of the previous Cantabile session (log-previous.txt) and the log of your current session (log.txt).

The best of luck with your tests!

Thank you, @cdv_gabriel for the thorough reply!

I saw that while recording that snippet the time load went over 100%, wasn’t sure what it meant. I am cleaning up the mix to reduce that. As far as glitches, none. At least not after matching all sample rates.

As far as the audio interface, I have 2 devices configured. a USB microphone and the Behringer interface. I did have some issues with glitched audio before with both connected, but that was related to the sample rates not being matched.

When this issue happens, all input sounds disappear, including mic. Not sure if this means anything or not.

As for the double buffer, this was an attempt to “fix” the issue. I did look at the logs, but I’m not expert enough to know what to look for.

Reading through the forum I saw an issue working with VoiceMeeter, but didn’t think it was related. But I want to add that I am working with VoiceMeeter where outputs go to voicemeeter which routes the audio to the correct channel(s). I didn’t think It would interfere.

Again, thank you for the response! Any more suggestions are greatly appreciated. Hopefully the reduced load time will help some.

Update: Reduced the timeload to between 30-40% under load. Issue persists :cry:

Will test wave generator shortly.

Hi again.

Just a quick response, since this sentence above sound strange. I also use VoiceMeeter, which means that I select the VoiceMeeter ASIO Driver in Tools->Options->Audio Engine (VM-VAIO if I remember well).

Then VoiceMeeter deals with the communications with the Audio Interface (a Steinberg UR22 mkII in my setup). Therefore, I don’t understand why Asio4All appears as your ASIO driver of choice.

In my setup, the audio input gets first to my audio interface, then (through the audio interface driver) it enters VoiceMeeter and finally from VoiceMeeter it gets to Cantabile (through VoiceMeeter ASIO driver). The output from Cantabile follows the reverse path: Cantabile->VoiceMeeter ASIO driver-> VoiceMeeter->Audio Interface Driver->Audio Interface.

If VoiceMeeter is also set to use Asio4All, in your setup, this could produce unexpected behaviour, IMO.

Just my 2 cents,

Interesting. Voicemeeter doesnt use asio in my case. Voicemeeter only mixes my outputs and I’m using the KS drivers. Inputs go directly into Cantabile as I like to have some separation and control of whats active and what isnt. Now I’m thinking of re-organizing the whole thing.

This is my setup:

Interface audio through ASIO4All → Cantabile → VA Cables (direct outputs)
|-> Monitor channel (voicemeeter)

Maybe this screenshot would explain it better?

Just to add to the discussion Behringer interfaces intermittently mute instead of glitch when overloaded as a rule. At least the 204HD does and the X18.

Interesting…I didn’t know that, @dave_dore. Maybe, if this actually happens in the OP setup, it could mute his USB mic, too?

I see…I have never tried something similar to your setup so I can’t be of much help. I always use ASIO, to minimize latency. Moreover, VoiceMeeter for me is not just an output mixer. It is at the center of my setup, which also includes Cakewalk for recording. My inputs also go through it.
I think it looked just simpler to me, when I set it all up, making all my sound streams go through VoiceMeeter using its ASIO drivers (I just have to select them both in Cantabile and in Cakewalk) instead of VA Cables.


Yes, instead of a pop or click you get a dropout (or mute). At least that how my Behringers behave. It would mute sound if fed through that interface at the end IMO.

Very interesting, I have the same interface so will try another and test. Thank you both so much, I’ve been chasing this issue for a while thinking software. Out of curiosity is there a way to prevent/reduce overload on the interface or would I need to get a more powerful one?

@cdv_gabriel I would love to see your setup. I have experimented with having VoiceMeeter handle the signals but couldnt figure out how to separate the inputs from VM in cantabile (each input has a different set of effects). I’d like to talk more and pick your brain a bit if you’re up for it.

Hi Acito,

The interface is not usually the problem. Most drivers on modern devices are on par. The CPU speed and disk streaming speed of your PC are the biggest issues. More physical cores can help in some cases but won’t help if you can’t get the samples off the disk fast enough to process them. And running 6 instances of Kontakt at the same time is a big load for the system. I highly suspect that the 6 instances of Kontakt is the reason you are bogging down. You are having to stream at least 6 sample libraries at once. At least that’s my ideas on it.

Hope you work it out. :slight_smile:


Hi @Acito,

my setup is relatively simple. I configure VoiceMeeter (A1) to use the ASIO Driver of my audio interface (Steinberg UR22 MkII). The interface has two inputs, which arrive as a stereo pair in the leftmost strip of VoiceMeeter (Banana).

In both Cantabile and Cakewalk I choose the VoiceMeeter ASIO (VAIO) driver. The inputs of my audio interface appear as VAIO Inputs 1 and 2 in Cantabile and Cakewalk (I have to select the B1 button in the leftmost strip).
In Cantabile I assign them to two different mono ports (I use one for a mic and one for a guitar). Cantabile’s output appears in the VAIO strip of VoiceMeeter and so does Cakewalk’s. I select A1 in the VAIO strip to send its output to my audio interface.
With this setup I am also able to record the output of Cantabile directly into Cakewalk.


Free eBook: Glitch Free - Cantabile - Software for Performing Musicians

Thanks, I dont think its the cpu, I’m running a 12-core Ryzen 5900x, and 64GB memory, and all ssd’s and M2 drives, no spinny ones. My CPU load is usually at 20%. I used to have a shure sm58 running through the interface and thinking back, I replaced it with a USB mic cause people were complaining about “audio quality issues”. Thought it was the mic, got it used 15 years ago lol.

I ordered the 404HD to see what happens.

@cdv_gabriel Interesting, I will try that, I do have a bunch ofunused channels in VM Banana. Thanks for sharing that. One question though, with that setup can you separate the 2 inputs from the interface and have each go through different effects? I have 2 guitar inputs, one from an acoustic preamp the other goes directly from elec guitar to amp emulator plugin. I need them separated.

@brad thank you kindly!

I will update as soon as I get some results

In Cantabile, you just have to navigate to Tools->Optons->Audio Ports and create two mono audio ports. Assign channel 1 of the interface (or left or whatever it is called) to one port and channel 2 (or right) to the other. Then, in the routing diagram, you will have two ports which you can send to different processing chains.


Audio interface replacement solved it. Thanks all for all your help. I learned a lot from this conversation. I also learned not to rule things out without troubleshooting them lol.