iConnect MIDI 2+ setup?

Just got one of these, and I have USB connected to iPad (port 1) and laptop connected (port 2)

Tried sending a song change message (in a setlist) and nothing is happening at the Cantabile end.

I have port 1 set in options (as a trial) and I get MIDI key messages going in to the VST i am using, but nothing happening on the song change side of things.

Is there a specific way to set this device up in Cantabile?


Hi @pax-eterna

Cantabile doesn’t respond to any song select messages by default - you need to configure a binding for it.

Try this

  1. Go to the background rack -(View menu -> Background Rack)
  2. Switch to the Bindings tab
  3. Click Add Binding button and choose “(learn)”
  4. Send a song select from your device - it should show up as an event in the Learn binding window. Select it a press OK
  5. On the right hand side of the binding choose Target as Set List and then on of the song select targets.

If you get stuck anywhere along the way, post some screen shots and I’ll check it out.


Thanks Brad, yeah I already have that set in the background rack. For some reason Cantabile is just not seeing the message. Data is being sent from the iPad, the MIDI led’s flash on the iConnect when the command is sent. I did not try the “midi learn” thing but not sure it would work over me already setting the binding as banked program change, on the channel required set to setlist the song select by program instant.

Hey Dennis

can you check if Cantabile is receiving the data? Right-click “input ports”, select “Midi monitor” and select the port that the messages should come in.

Then send the messages from your iPad and check if Cantabile is receiving anything. If you see messages in the monitor, you can at least be sure that they arrive - then you can concentrate on Cantabile dealing with them (bindings, background rack).

If you don’t see any messages, check your MIDI port configuration (port assignments / filters) to make sure the physical MIDI port is actually connected to Cantabile.

Also, check the routing and filtering setup of the iConnect Midi2+ to make sure that the messages sent by your iPad aren’t filtered out. iConnects can be a bit convoluted in their configuration.

What messages are you using for selecting songs? Best would be program changes, ideally banked program changes (with CC0/CC32 for bank select). Normally, these don’t get filtered. Or are you using “song select” messages (0xF3)?




I’ll ask the obvious:
Have you correctly set your MIDI IN/OUT Ports under Tools? Are the Two USB Ports, Two DIN ports and the DIN Connector IN/OUT connected properly? I use the ICM2+ and the ICM4+ without issues.


Thanks Herbert.

@Torsten - thx m8 - checked that out, and at first got nothing then had another look via the config tool and reset the iConnect back to default (I had changed the names) although the config tool is a bit confusing in operation TBH (well for me anyway) so maybe I did something else without realising.

Anyhoo went back to C3 and then enabled every iConnect option in the input ports. Got it working so that program change now selects the song. So, lats query is exactly WHICH port does the data from the iPad come from? I like tidiness and would prefer to not have every port open. Only the ones necessary. But I cannot figure which USB port (obviously the USB connection the laptop is connected to haha) out of the several available…


Hey @pax-eterna,

which config tool are you using - Auracle or iConfig?

iConfig is definitely a bit complex, but very powerful once you wrap your head around it.

Important: iConnectivity interfaces provide 4 MIDI ports on each USB port, so let’s say you have your iPad plugged into USB 1 and your Cantabile laptop into USB 2. Then your iPad “sees” 4 MIDI devices from the iConnect; the laptop also sees 4 devices.

Now you can create MIDI routes between the 4 devices on your iPad, the 4 devices on your iPad and the 2x2 DIN inputs/outputs. By default, the routes should be like the default naming:

This means:

  • Port 1 on your laptop is routed to / from the first DIN input/output pair
  • Port 2 on your laptop goes to the second DIN input/output pair
  • Port 3 on the laptop goes to port 3 on the iPad and the other way round
  • Port 4 on the laptop is not routed.

So to send MIDI data from your iPad to your laptop, you need to use output port 3 on the iPad and input port 3 on the laptop.

You can pretty much use the default configuration on the Midi2+ like this; but there are some modifications you might want to make:

  • if you don’t want to send MIDI from your keyboards to your iPad directly (but rather route all MIDI comms through Cantabile), you could remove the routes between the DIN ports and the USB 1 devices (both input and output routes).
  • if you want to use two different devices between your iPad and Cantabile (e.g. one for note data, another solely for control data), you could create an additional route between device 4 on USB 1 and device 4 on USB 2 (and vice versa). Now you could use device 4 only for song select commands and device 3 for any MIDI data you want to send to your synths from your iPad

Hope this helps!



Thanks Torsten - tbh that is the first time I have seen that graphic! Makes much more sense than the iConfig app…I have installed Auricle but all I get is the three stage setup dialogue and that’s it. It goes no further :frowning:

Nope, just installed Auricle on the laptop and all I get is that three stage setup and NO (midi or audio) routing data comes up, is shown, nada! All devices are connected.

Since you’re still learning the ICM2+, I suggest using iConfig and restore the unit to Factory Defaults. They work out of the box that way. The iCM2+ is pretty basic. iOS device in USB 1, PC in USB 2, DIN 1 & 2 connecting to hardware (OUT from iCM2+ to IN on Hardware, OUT from Hardware to IN on iCM2+.

IN Ports USB 1 & 2, DIN 1& 2 to Cantabile. OUT Ports USB 1 & 2, DIN 1 & 2 to the Hardware.

There are quite a few How-to videos up on the iConnectivity Channel.


yeah thanks Doug - already did that. What I need to happen is for midi note data to go back out of C3 to a vocal device that is hooked up to the MIDI out port of the keyboard. And further this needs to see transpose data for several song files, but it is not.

I tried hooking the vocal device to an out DIN port on the iConnect with the same result - nothing! haha I’ll keep trying though. I’ll check the channel you mentioned but I have it all pretty much runnning, just got to figure getting data to the vocal box.

How should Cantabile send MIDI data to the Out port of the keyboard? Can you describe the setup in a bit more detail - difficult to speculate what is happening here:

  • how is the keyboard attached to your Cantabile laptop (iConnect MIDI 2+ or USB)?
  • How is the vocal device attached?

If you want to send data to the vocal box from your keyboard through Cantabile via MIDI, I would recommend to:

  • connect the keyboard to Cantabile via iConnect DIN input 1 (keyboard MIDI out → iCon MIDI In 1)
  • connect the vocal device to iCon MIDI Din output 1 (unless something else is attached)
  • Create a virtual output port in Cantabile and call it “Vocal Device”. Assign iCON output port 1 to it (assuming default routing)
  • Create routes in Cantabile that send MIDI data from your main keyboard to your “Vocal Device” output port (including transpose settings)

Now the output from your keyboard should be processed by Cantabile and routed to your vocal device.

This is essentially how I do things with my VoiceLive - the only difference is that I have encapsulated my VolceLive in a rack so I can switch presets directly in Cantabile by choosing a preset (using bindings inside the rack that send program changes triggered by rack states).




Is there no MIDI Thru on the keyboard? I always thought the OUT port was to return MIDI data back to the source. The THRU passed Input day from the source to another connected device.


No, just one IN and two OUTS Doug.

Torsten, I’m pretty sure that’s how I did have it setup, but I’ll double check your recommendation…thanks for explaining it in detail.

Controller is attached via MIDI in to the ICM2, Harmony M is attached to the ICM2 out port.

The ICM2 ports I can see in C3 are (exactly as written) ICM2+, MIDIOUT2 (ICM2+) - MIDIOUT3 (ICM2+) - MIDIOUT4 (ICM2+)…There is actually no specific out 1 listed?


And one quick follow up question Torsten please, I know the device is supposed to be ok as is, but would installing the iConnectivity MIDI driver make any difference?


Tried that setup Torsten, well as near as I can as I do not have a specific MIDI out 1 listed…still no note transposition :frowning:

Hey Dennis

The ICM2+ port is output 1 for your laptop - for the ICM, it is then USB input 2, port 1 - that is by default routed to ICM output DIN 1.

I don’t think that installing the drivers makes any difference - I’ve got basic MIDI communication to work both ways. It’s just that the configuration tool is a bit flakey - can’t remember how it works better, with the plug&play setup or with the drivers.



Can you show a screenshot of your routing? Might make it easier to diagnose. Especially: how is the transposition achieved - global transpose or route transpose?



I need it to be global transpose. But for some reason the note data going back to the Harmony M is not getting transposed.

I’ll try and get a screenshot up.

Check the route properties: