How to use "Only route when CC"?


I want to activate some route only when some specific CC is set.
The “Only route when CC” option seems pretty obvious, but I can’t make it work.

For testing purposes, I created a route from my midi controller to some VST plugin … but when I set the “Only route when CC 83 is greater or equal 64”, the route stops sending midi messages to the VST plugin, even switching CC 83 to zero and back again to 127.

Some additional info:

  • My midi controller is sending notes on channel 01;
  • The CC 83 comes on channel 13, and it is triggered from a button of the midi controller;
  • The route is receveing messages from all channels and mapping them to the same channel;
  • I tried to create a midi filter, to map CC 83 on channel 13 to channel 01, but nothing changes;

Does anybody have any idea of what I’m doing wrong?

Can you share a few screenshots of your settings and filters for the route?

1 Like

I suspect the problem is the CC being on Channel 13, which I believe cannot affect MIDI going in or out of Channel 1. I think it has to be all on the same channel.

If I recall, even though the filter icon (little funnel) appears first, it actually gets its datastream after the second icon, which is the MIDI routing control. So, placing filters into the filter tool will not affect the routing control stream since it gets its input from that control.

You might be able to use a loopback (turn “Show Loopback Ports” on in the Miscellaneous section of Options) or bypass the MIDI routing tool altogether and replicate the actions using bindings if you have that capability in your version of Cantabile.


1 Like