How to get faster song switching?


#21

If it reloads samples you did something wrong. You do not switch presets and you preload the setlist, right?


#22

I’m just not sure how this would work practical? Any idea here? The switching proces?


#23

@So_Godly: can you clarify? What is the question? Sven feel free to pm le!

As for @matejb 's comment: I do this for dozens of Kontakt libraries (some of which that take ages to load) - and have zero switching time. Obviously the flipside is that Cantabile startup time goes up.


#24

Yes but you are probably not using Kontakt in a linked rack AND selected “Entire Bank” in plugin State Behavior (the first checkbox - song based).

If I have this selected, then samples reload every time I switch to a song.

If instead I select parameters to be exported manually, song switches instantly.

Am I missing something?


#25

@matejb : I’m not sure what you mean, but here is an example screenshot of what I do.

  • I have a linked rack - in this case it’s called Piano’s Linked
  • That has - in this case - 9 different piano’s in it. - 5 kontakt piano’s (all in 1 multi) and 4 instances of Keyscape
  • Each of those piano’s listens to a different Midi track
  • In this song, every state plays a different piano. E.g. State 1 does a bright Keyscape Piano, on Midi 1
  • There are bindings, mapping the input device (which is hidden in a “Fader Rack” in this case) to the appropriate midi channel - depending on the state, the relevant binding is activated and the others are deactivated.

Pic below show the linked rack:

I didn’t include a pic of what’s inside the Kontakt multi but you get the picture I guess? It is simply 5 piano presets, each on their own midi channel (2-6 in this case) If not give a shout and I’ll post that as well. Keyscape does not do multi’s so I have 4 instances of Keyscape loaded, each with their own piano preset (as you can see).

Works great! Hope this helps clear up your confusion?


#26

@Tom_Tollenaere Again - you DON’T use the “Entire Bank” state behavior (as I marked in my above screenshot) and this explain why you don’t have issues.

I don’t have issues either, I just made a comment that using the “Entire Bank” state behavior will cause samples to reload even if preloading. And it makes sense when you think about it - I just made a comment to warn new users that might have trouble with it just as I had once. Again, this is not a software issue, it’s an issue about misunderstanding what the option really means and does.

Now - the “Entire Bank” means just that - “remember and reload entire bank including samples for each song or rack state”. While this is a nice shortcut for non-sampled instruments, using it with sample libraries it will slow song loading down.
Regards,
Matej


#27

Yes, you are right I do not use entire bank (don’t see why I would really :slight_smile: ).