How to assign knobs of a controller to another vst rack?


#1

Hi community, Hi brad !
I am discovering cantabile. Very good soft…
I’d like to know if it is possible to assign knobs to a vst instrument wich is in an other rack…
por example : i use a m-audio code 61 and a korg microkey 37. I made two racks, the code 61 is routed to the piano rack (minigrand) and the microkey to the synth rack (the legend)…
The microkey doesn’t have knobs, so can i assign the m-audio code knobs(playing pianosound) to the legend vst knobs.?
I try to learn midi cc… But it only works when the controller and the rack are routed together…
i am french and my english is not so good… Haha… I hope you understand my request…
thanks!


#2

Hi @Santinho

You can do this in one of two ways… either make sure the appropriate MIDI is routed from the song to the Rack’s MIDI In and then create the binding inside the rack from the Rack’s MIDI In port.

or…

In Options -> Miscellaneous, turn on Show Environment Audio and MIDI Ports in Racks which will let you create bindings in racks directly from environment ports (eg: Main Keyboard).

Brad


#3

Hi David and Welcome to the Community,

Which version are you running, it will help answer your question because they have different abilities and that affects how you would do it. I assume it is Cantabile Performer or Solo, is that right?

Since you have both keyboards as sources using bindings would be the way so you go to the bindings tab at the song level. Then you can use MIDI learn to get the source keyboard and knob selected and loaded as the Source of the binding.

I turned the mod wheel and got this and selected the Code49 from the choices and hit ok

Next you select the target from the list

and finish filling in the fields for the Mod wheel knob to the Legend Rack MIDI In

and here’s the finished binding

You can use either keyboard as a Source and either Vst Rack" as a Target and configure from there

Dave


#4

Hi dave! Yes it was performer version… Thanks a lot for the explanation with the pictures. It was very helpfull !!!:wink:


#5

Thanks brad!
It’s ok now!! :wink:


#6

Thanks brad!
it s ok now!! :wink: