How do I stop volume "jump" for media player control?

I am using an external controller mapped to control the gain on a media player, however I either need to turn the knob hard right or left to pick up a level, and/or the volume level “jumps” to the adjusted knob level…

How can I set it so the knob is already at the level preset in the song so that if a minor tweak, when playing live, is needed the transition is a smooth one?

Have a look at this guide, which covers jump prevention as well as relative continuous controllers. I use jump prevention all the time, whereby if a state/song change sets a parameter (say a gain control) to a certain value, moving the associated controller will have no effect until it passes through the new value, after which it will track smoothly. As long as you know roughly where the value is, it’s fairly easy to move your controller to “pick up” control. Another option (which I haven’t tried) is to use relative controllers (ideal if you have endless rotary controllers), where turning will always apply a change relative to where the value currently is.

Hope that helps.


thanks Neil - yes that relative one is probs the one to go with…I’ll check that guide again, but it wasn’t apparnetly clear to me how to actually achieve it haha…mind you I did read it many moons ago, so maybe it has been updated…

nah, still no clearer hahaha! No probs I’ll keep playing with it. Even in Jump Prevention it still jumps a bit…I ws sort of expecting some smoother transition :slight_smile:

It should not jump at all with jump prevention - it never has with me. It’s literally just ignoring controller input until it passes the current value, then continues with it, from that point.

Check you’re not sending multiple different controllers to the same parameter - if you are, then you may be sending interleaved different controller values, and no software is going to make any sense out of that.


oky dokes will do - thanks