HiDPI Not working with latest Arturia

I’m having an issue with Arturia V9 plugins and HiDPI scaling. It used to work with if I shut off “Plugin GUI Up-scaling”. Now it scales incorrectly. I have to turn it on, then use Arturia’s scaling to lower it under 100%. While this works the result is pixelated as can be expected.

Anyone else having this issue? It could be from my recent video card upgrade, but I’m not sure as I updated the card, Cantabile and Arturia in the last couple of weeks.

Sorry to bump this, but I think it has to do with build 4059. The update specifically “fixes” some issues with HIDPI and upscaling.

Brad: You might want to take a look at Arturia plug ins. Let me know if you need anything from me.


I’m using build 4059 and the latest version of Arturia V9 - I don’t see any problems when setting Cantabile to HiDPI “Enabled” (without “Upscale Plugins”).

Next, I checked “HiDPI Enabled & Upscale Plugins”. As long as I uncheck the Compatibility box “Enable GUI Upscaling” - these plugins scale very nicely and show a large and crisp GUI on my 4K monitor:

I just need to use their system menu to set a decent size for the plugin window:

So it looks like the plugins and Cantabile are fine; at least on my system - maybe something with your graphics card?

What specifically is NOT working in your setup? Maybe you can share some screenshots so we can get to the bottom of this.




Thanks for checking!

My issue is compounded because I upgraded my video card and Cantabile around the same time. I rolled back to an older build and the problem persists, so it is my video card. Have to figure out why it is affecting things.

Another update: If I enable OpenGL acceleration in options the entire interface has the issue. So my guess is the Arteria is using something in their interface related to OpenGL that causes the same issue. If I enable only HiDPI (turn off upscaling) everything works correctly.

Torsen: Can you check if it works correctly if you turn on “Upscale Plugins” in “Options”, and turn off upscaling on the Arturia plugin ?

Yes, that’s what I did - see the post above:

Again - can you share some screenshots so we all can see what exactly is happening? Currently, we only know that you “have issues” and that plugin “scale incorrectly”. Not a lot to go on, unfortunately, so better if you can demonstrate how the issues manifest…



Sorry, I misread your first response and missed that you had tried it.

Here are some screenshots of the issue:

  1. My Options settings:

  2. Compatibility settings for Arturia Plugins:

  3. The result:

No matter what the scaling is set to the window is drawn outside its bounds.

Don’t know what happened, but now I can’t reproduce the issue. No matter what settings I tried and multiple reboots didn’t fix the issue. Now it works no matter what I try. Strange.

Thanks for the help. If it does happen again I’ll do more digging.

With the Arturia plugins, I suggest to remove the checkmark for “Enable Plugin GUI Up-scaling” - Arturia plugins are hi-DPI-compatible, so they don’t need to be upscaled. Upscaling is for older plugins that would just be too small on a hi-DPI screen.

Can you try it with the “up-scaling” checkmark removed?



Those images are with the checkmark removed. I uploaded the wrong screenshot. :frowning: Sorry. I was taking the screenshots for a bunch of configurations. However, even if it was checked it would normally upscale the entire window and not cut it off in the bottom right.

As mentioned above, it appears it is not longer causing an issue for me though. Not sure why. However if I upscale the window “Enable Plugin GUI Up-scaling” checked:

Kind of weird. Not that I’m concerned though as Arteria now seems to be working right when scaling is turned off.