Help With Automatic Changes After Version Upgrade

I read the community pages everyday, and try to keep up to date on most things when I have time. I gig a lot, and don’t make version changes unless I have time to test everything. I have been stuck on version 3220 because I started having problems with automatic changes on states. Below is an example of what I am experiencing.

Here I have a Scarbee output to mono out 1 and VB3 output to mono 1. Both are active. I set them up to be active throughout the song. I have state changes on this song that only changes lyric pages. I set this particular song up several months ago without any problems. Both VSTs are not in a rack. So, now I switch states, and things start going haywire. Below is my 1st state change.

Now the Scarbee is disabled and the VB3 has changed output ports. I went to a rehearsal and many of my songs went south after a state change. I realize there have been a huge amount of requests and many updates in the past several weeks, and haven’t been able to keep up. I don’t understand tho why any updates would cause a large portion of my existing 480+ songs go south on me. Is there a new addition to a menu item I need to either check or uncheck? I just find it really frustrating to have to go thru every setup I have to correct the problems before the next gig, which is always 2 or 3 days away. Thanks in advance for help anyone can give.


Hi @Corky,

I’m guessing what’s happened here is related to the order in which you setup things. When you add objects (plugins/routes) to a song or rack after states have been created, when you return to those saved states Cantabile will try to reset things as they were when the state was saved by disabling newly added items.

So… in your case if you saved your states before you added the route from Scarbee to mono out, then when you return to those saved states the route will be disabled - cause that’s (kinda) how it was when you saved the state.

The easiest way to work around this is turn off the Enable state behaviour for that route - it’ll then not be controlled by states and remain enabled.

Does that explain what you’re seeing?


Hi Brad. Thanks for responding. What I had discovered, the hard way, was something went wrong with many of my songs that have been working well for several months. After reading your message, I realized that I had to make a change to route my plugs to a mono channel due to an equipment change. I will use your suggestion to turn off the enable state behavior for the route. As always, you saved the day ! Thanks again.