Help Setting Up MIDI Foot Controller - With NO KeyBoard

Tags: #<Tag:0x00007f978c2c8640>

I am running Cantabile 3 on a Windows Surface Pro 4 Tablet. I use a Zoom UAC-2 audio card, and my instrument is an electric violin. I am NOT a keyboard player [don’t take it personally], so I don’t have much experience with MIDI. I have a Behringer FCB1010 MIDI Foot controller, because as a violin player, my hands (both) are always busy, so I only have my feet to send MIDI messages.

I’m having trouble getting things set up.

First, even thought the Foot Controller isn’t a keyboard, the only IN MIDI devices in the MIDI ports settings dialog are the on-screen keyboard and the Main Keyboard. So… I routed the MIDI IN from my audio interface card which is connected to the foot controller to this Main Keyboard – is that correct? [see picture]

Then what do I do? I tried to set up a binding, but what about the Input Port routing? Do I need to do something there?
I tried setting up a binding, that is bind the Main Keyboard, which is really the audio interface MIDI input, which really is connected to the foot controller. The target of the binding is the gain to the rack I’m trying to control by MIDI Continuous Controllers. [see picture]

Is there a better, or more clear tutorial video on this?
How can you “test” or know that the MIDI Input messages are coming through?
Any advice or video tutorials would be GREATLY appreciated!!!

MIDIless in Midland

Hi Alex,

First off, you can even change the name from Main Keyboard to say, MIDI Pedal IN by selecting it in the ports menu and pressing edit. Also you might want to start by setting the source channel to Omni if you don’t know the channel number. You could also just use the learn function.

  • click add binding
  • press button or move pedal on your foot controller
  • Cantabile fills in the first parts like source and event
  • you fill in the target parameters by hand

Secondly, the round indicator at the beginning of your binding line in your picture is a MIDI activity indicator. It lights up to tell you if the controller (foot pedal in this case) messages are reaching the binding. There is also a way to use the midi monitor ( View>MIDI Monitor ) but you need to go to the routing page first and select the midi input you wish to monitor from the input table. Hope this helps…:smiley:

1 Like

Hi @Vmusic

Dave’s post mostly covers it. Just a couple of things…

You say you want to control the input to the rack. What you’ve got in your screen shot will be controlling the output gain of the rack. To control the input you probably need to adjust the level of the route that’s feeding the rack’s input.

Creating bindings to routes however requires a secret trick - you need to give the route a name before it will appear in the bindings panel. So try this:

  1. You should have an audio route somewhere on the routings panel that connects to your racks audio input.
  2. Select it and from the Edit menu choose Rename.
  3. Give it a name. eg: “Rack Audio In Level”
  4. Now go to the bindings panel and you should find that route now appears in the binding targets column and you can bind your foot pedal to it.

Make sense?


Hi… first thanks for the help. I haven’t gotten it yet, but I think it’s the FC not sending the MIDI messages. I have seen on line the Berhinger FCB1010 takes a rocket scientist to set up. NOTE: Don’t recommend this to anyone.

I did rename the routing out from the object before the rack, that sends the signal to the rack… sadly, the name in the Preset/Destination doesn’t change??? In the binding tab, trying to set up a MIDI binding it does show up in the binding Target list.

QUESTION… if I add a binding using the “learn” method, as shown below, and I select my MIDI foot controller, and I press the buttons/moved the foot pedals ---- but it doesn’t see any signals — then am I to assume the FC isn’t really sending MIDI messages???

A couple of other things to check/test:

  1. In the Monitor panel does the MIDI FC port light up when you move the pedal?
  2. Do you definitely have the port bound to the MIDI source device correctly (perhaps post a fresh screen shot of you MIDI Options page)
  3. You could try turning on the console logger and see if any MIDI events are being received - Options -> Diagnostics, turn on Console Logger and Log MIDI In Events. A second log window should appear and if you move the pedal you should see any received events appear in the log window.


Hi Brad,
Here’s the log dump… it’s saying “unknown MIDI message”, so it seems to be something wrong with the way the FC is set up, perhaps?

Here’s the MIDI port in the set up dialog

Are those messages coming in continuously or are they only when you work the foot controller?

(I’m wondering if they’re active sense messages and wishing it actually logged out what the unknown message was - so I’ve added that for the next build).

If you are looking for a replacement floor controller the Line 6 FBV series have been great for me. I have both the FBV Express Mk II and FBV Shortboard Mk II. They come with a great piece of software for configuring each button that is really just a piece of cake to set up.

You can see on the right of the lower grid you can set switch mode to basically make anything work, increment, decrement, momentary, single, toggle, different CC for up and down. With these controllers and a few of PizMidi plugins, I’ve been able to control anything I’ve wanted to in the exact manner I’ve wanted to.

Thanks, good luck!.

1 Like

Hi @Lempface

That looks pretty cool.

I’m curious if you’re to use PizMidi in Cantabile? If so, is there anything I could add to Cantabile that would simplify things and not require the plugin?



I’m gonna start a new topic so it doesn’t get buried here, just in case it may help someone else.

Thanks for the suggestion!!! After spending 6 hours trying to get a simple foot controller working, it’s extremely frustrating to say the least. I found that somebody wrote a windows [and Mac] programs to do this sort of thing for the FCB1010 by Berhinger, which is what I bought. I installed it (the software), and while it could read a simple change command, I haven’t been able to get it (the windows program) to program or set up the foot controller.

I am not at all familiar with PizMIDI?

I’m a technology architect, and while I’m not even close to honestly understanding all of this, it does “feel” like we’re using 40 year old technology that has long, long, long, long since outlived its effectiveness. It “feels” like we’ve rigged it (MIDI) to do everything including putting food on the BBQ.

Churned in CBus

The PizMidi plugins are very simple plugins that can help you achieve most anything in midi.
Definitely worth grabbing and playing around with since they are free.

Vmusic, sorry you’re having such bad luck with that Behringer. I considered buying that one too because of the price vs number of switches plus the two foot rockers. But I read about people needing custom firm ware to get it to work right and some folks were just never able to get it up an running.

The FBV series from Line 6 I had running in under 10 minutes. One piece of software to install, and after that it just works. The only problem I have had so far is using the control app to configure both pedals at the same time. The software is supposed to support this and allow you to switch between them on the GUI but it doesn’t seem to work, it just locks up the software. So the minor inconvenience is to turn on controller off (Love my usb hub w/ power switches) configure it, close the app, turn that one off, turn the other back on, relaunch the app and configure the 2nd one. But because I’m not modifying the messages from the pedal at the driver level, I only had to do that once.

Here is the link to the custom firmware I had been reading about while researching. You may want to try it out: Do so at your own risk of course as generally using custom firmware voids warranties and such. Don’t blame me if you brick it, in other words. :slight_smile:

I am thinking about getting one of these Line 6 FBV Shortbaord MKII — however, it only has a USB out, right?

SO… inside Cantabile, how do you have your ports, both Audio and MIDI set up? Are you playing guitar?


I’m not 100% sure what you are asking?

The shortboard only has USB out, that is correct (well it has ethernet out as well but that’s just for interfacing directly w/ line 6 Amps). When you install the driver software which gives you the configuration application, when you plug in the device, you’ll see the shortboard show up as a midi device in your audio application.

I use an IK Multimedia iRig Pro HD to get my guitar signal into the computer and the shortboard and fbv express to control amplitube/gloop and then a 25 key Arturia Minilab keyboard. Everything works great in Cantabile.

Perhaps you can tell me more about how you connect and I can give better advice. (Part of your question made me think you may have thought the shortboard has audio in, I just wanted to clarify that it does not, you’ll see need an audio interface for your guitar. But AFAIK the FCB1010 doesn’t have audio either, so you probably already have an input device.)

First REALLY Thanks for your help!!

I have a MS Surface Pro 4 where I’m running Cantabile. Sadly the Surface Pro 4 has only one USB input. I can of course get a USB hub.

My vst plugins run in/through Cantabile, I have a few of them listed below.

I use a Zoom UAC-2 Audio Interface for both my audio signal [electric violin] and my MIDI foot controller, which right now is the Berhinger (if I can get it working).

Well… it’s funny. Somebody made PC Software that is supposed to let you “set up” the FCB1010 but I don’t know how to use it. It (the software) DOES show - that a MIDI signal is coming in, but just a change signal.

However… Cantabile isn’t recognizing any incoming signals :cry:

Wow, seems like Behringer has done a stellar job of making an easy to use product. (Not!)

It’s a bit hard to help from here without really understanding what the device is sending. The new build of Cantabile 3161 which I just put up now logs the actual bytes received with the “Unknown MIDI message” - perhaps that can provide some clues.

Besides that if someone can figure out how to get the device to send something meaningful I’m sure we can figure out a way to make it usable in Cantabile.

Well… there’s more one way to skin a cat, so to speak, and Berhinger isn’t one of them

1 Like