Having trouble setting up "Panic" button

I thought I would use Custom Button 3 - set color red - assign it to “Tools > All Sounds Off”. I was expecting the green power icon in the upper right to grey out". That doesn’t happen. Pressing the custom button doesn’t stop sound either. My last step was going to be to bind that custom button to an unused button (away from the others!) on my Axiom keyboard.

I’m pretty sure this isn’t the way to do it. Help - I’m motivated because I’m using Hybrid live for the first time and a few times I’ve gotten stuck notes that only restarting Cantabile would resolve. It had something to do with modifying the song states that I’m using to change plugins in the linked rack.

BTW, in the spirit of workstation style Cantabile use - I followed dave_dore’s instructions Switch plugins in linked rack using song states and then assigned the 8 pads on the Axiom to switch. Then I labeled them as follows:

Each state is saved for the single patch I will be using for each plugin (all controls for VB3 are available with sliders and buttons).

I mainly use controller bindings wich Engine / All Sounds Off for “Panic”: see here:

But I also have a toolbar button set up for this - and it seems to cut off sounds quite nicely:

I just played and held a note in a softsynth, then pressed the button, and the notes were instantly stopped. Of course, the release phase still rang out, and so did the reverb effect tail. This is due to the fact that all these functions will NOT turn off the sound engine - they will simply send note-off and some MIDI reset commands to all plugins. Just like hitting the “exclamation” icon at the top does:

So no stopping of the audio engine with these commands. If you really need to do this (not sure why), your binding would have to target “Engine / Restart Engine”. This will brutally and completely shut off all sound and restart the audio engine. Just tested this with a sustain pedal binding - works nicely:



1 Like

Thanks - your explanation of the difference between “All Sounds Off” and “Engine/ Restart Engine” really helped. I’ll follow your Global Rack keyboard binding method for my midi controller “All Sounds Off” button .

I have to say I regularly used “All sounds off”, “Panic”, “Reset” each, and in combination with my pre-Cantabile rig (Forte). I can’t recall ever needing one since I switched. I still have bindings in the Background rack, but haven’t needed them.

No “hanging notes” issues with Cantabile so far (@brad has done an excellent job on avoiding the typical switching pitfalls), but my 49 key controllers do freeze now and then (it’s a nasty issue with the aftertouch on the M-Audio Code 49; similar issue with the Alesis VI 49, seems they are built on similar components), so it’s really useful to be able to quickly mute any hanging notes before switching the beast off and on again. That’s why I have a button labeled “PANIC” on both of my controllers so I’m sure I can find one that still works…



Sehr interessant! I haven’t had that with the Novation SL keys, Kurzweils, or Rolands. I’m in the process of trying out a Behringer as a potential main kb replacement. We’ll see how that goes. I haven’t mapped a panic button to the Behringer yet.

If you have time, it would be very interesting to hear more about the Behringer controller.

I haven’t finishing experimenting yet, but very positive so far. I’m using Blue Cat Remote to facilitate the moterized faders (I wish my keyboard had an o-umlaut!) :wink:

Hold down the ALT key and type the number 147 on your keypad and you’ll get “ô”

Complete list of codes here: http://www.asciitable.com/

1 Like

Of course, doesn’t work on my phone. :wink: I plan to do the review on a real computer. Mötor 61. There! :grin:


Just stumbled across this and it reminded me that Roland used to (maybe they still do, I haven’t purchased their hardware for years) have a scheme which issued an All Note Off command as the last note was released. Cubase has a default setting to filter out CC123, because it (the Roland implementation) was causing problems in some overdub situations. I’d really like to try and make that happen in Cantabile. I need to see if there is some conditional approach which can be applied. As noted back in '19, it’s a pretty smooth way to shut off notes without throwing the baby out with bathwater.