Hauptwerk VSTLink - GUI is Blank When Trying to Edit


#1

Hello. I am trying to use the Hauptwerk Pipe Organ in a rack in Cantabile 3 (64 bit) on a Win7 machine. The standalone version of the program works fine. I actually have two problems:

  1. If I add the 32 bit VSTi to the rack and try to edit it, a GUI window pops up, but it is blank.

  2. If I add the 64 bit VSTi to the rack and try to edit it, I get a popup saying, “the plugin has no parameters.”

I’m having zero issues with about 15 other VSTi and effects, so I know my Cantabile installation and configuration is solid.

Any thoughts?

Thank you very much!


#2

Hi Paul,

if you are running Cantabile 3 64 bit then you should not try to load 32 bit vsti plugins without the use of jBridge. Do you use jBridge? If not then the 32 bit plugin will not run in 64 bit Cantabile. It should however load the 64 bit plugin if it is in the proper folder with the ones that work already. Hope this helps.

Dave


#3

Thank you, Dave. I am indeed using Jbridge for my 32-bit plugs. The 64-bit version of Hauptwerk is installed in the 64-bit folder with my other 64-bit plugs, but it doesn’t even pop a GUI up.


#4

Hi Paul,

If you don’t mind what version of Cantabile are you running. Also you could try unchecking the high resolution support at the top of the General page in the Options and see if that has an effect. Past that you may need help from Brad.

Dave


#5

Hi @wd8dky,

As mentioned by @dave_dore, if you’re running Cantabile 35xx then could you try fiddling with Cantabile’s “Enable High Resolution UI” and “Use Per-Window Resolution Scaling” options and see if they make a difference.

As for jBridge, you shouldn’t need to be using it with Hauptwerk - just use the 64-bit plugin.

Brad


#6

Thank you all for your help. I need to apologize; I was certain that I had upgraded to v3.xx, but it turns out I’m still running 2.xx. Anyhow, I attempted to find a way to run Hauptwerk and Cantabile at the same time.

I was able to find a MIDI workaround using an ALT configuration of Cantabile to route the MIDI to both Cantabile and Hauptwerk, but my sound card doesn’t support running two apps trying to access the ASIO driver at once. That is a different issue that has nothing to do with Cantabile.

Again, my apologies for asking for help when I am running 2.x vs. 3.x This is a very nice community, and I appreciate the help you suggested.

All the best!


#7

The “no parameters…” warning is normal for Hauptwerk since it is not a true VST.and therefore has no parameters. All that is needed to run HW in C3 is an Output port set to HauptwerkVSTlink-64 bit. You do not need an input port for HW since midi controllers will or should connect directly to HW.


#8

Thank you! Does this mean I have to have the standalone version of Hauptwerk running at the same time as Cantabile? This is definitely an odd bird.


#9

yup, exactly - this is what their website says:

A new way to connect to your host.
The Hauptwerk AU/VST plug-in link changes the way you can use a highly optimized virtual instrument with your host program. Traditional VSTi instruments are limited in the amount of performance they can achieve when running within a Digital Audio Workstation’s own platform. To remove this limitation Hauptwerk itself runs outside of your AU/VST host as a stand-alone application and instead connects through the ‘Hauptwerk AU/VST Link’ in your sequencer providing a bi-directional bridge for MIDI routing as well as audio routing.

Running outside of the AU/VST host allows Hauptwerk to perform significantly better, and offers a richer user interface, integrates more tightly with digital MIDI organ consoles, works fully via touch-screens and for MIDI files to be independent of MIDI hardware and MIDI settings.

So the plugin inside Cantabile is nothing but a routing interface that routes MIDI to Hauptwerk and audio back to Cantabile. The rest is done by the Hauptwerk app - so you definitely need it running in parallel.

Cheers,

Torsten


#10

Thank you very much! That makes a lot of sense now. I’ll give that a try.

All the best,

Paul


#11

I’ve got it working now! Thank you all very much for the help.