GUI Sizing Oddity (Started, I think, with Build 3692)

Has anyone had an issue with the GUI as far as fitting the display equally or menus/dialog boxes opening in odd places?

I noticed that one of my User Buttons in the Controller Bar was WAY off-center to the RIGHT. It is a Clock Button (blue … I know, irrelevant) and the Blue takes up 2/3 of the display from the Left and the Click & Label are far to the Right. If I grab the Right edge to re-size the Button, one of the Default Buttons appears.

Also, I can’t seem to find the Right Edge of the GUI. I stretched it out across two 24” displays and still didn’t come to the edge. Full Screen mode doesn’t correct the issue and neither do clicking the Maximize button at the top right of the window or Minimizing the window and manually adjusting the GUI size.

Just curious,


I recently setup an 11" screen laptop and was experiencing some similar issues but attributed it to the smaller screen. Will pay more attention next time I’m using that computer.

Hey, Doug!

I didn’t pay much attention to the GUI not being centered (usually, the Maximize button on the window seemed to correct it). The fact that I couldn’t center the Clock button that I created for my Controller Bar caused be to think something screwy.

I’m going to investigate further tomorrow.


Of course you realize there are 3 Dougs on this thread. :smile:


I had this problem when I changed from a 32” to 12” screen, the way I found to fix that was to firstly un-maximise the main cantabile window, then open, drag and resize each pop up box to the centre of the screen or wherever you want it to be, then close everything and restart cantabile and the new window positions will persist :+1:

Have you tried reverting Cantabile 3692 back to an earlier version, just in case?

Yes, and that reminds me of one of my favorite Gary Larson cartoons: “Beware of Doug”

Hopefully, you’ve seen it.

BTW - I’ve just about finished (musicians/Cantabile users are always “just about finished”) setting up all of my Linked Racks. The B-5 and IKM Leslie racks are still dumping molasses on everything. I set up my controller to operate every important control on the B-5, including the the reverse preset keys and even set up a “half-moon” switch simulator with Fast/Brake/Fast operation. I did have to use a Controller Map to get CC16 (one of the draw bars) to go to the B-5 as CC84 to control the REVERB level. I even had a left over button to cover the Power Switch on the Reverb stomp box. I can load 8 drawbar Presets to the Reverse Keys and that’s more than I need. Thanks for the inspiration to get things right. :+1:



Thanks for the suggestion. I can do that, but that still leaves the GUI (as a whole) not centered in the display window.


1 Like

Glad you got it going!! Was wondering how you progressed. If you ever need to Zoom again, feel free to ask.

BTW…there are a few gui settings you can try out under options>general, if needed.

I saw those, but nothing fit the problem. Besides, imagine Cantabile @ 80% on a 8” Dell Tablet display. :flushed:

One of the more interesting tasks was setting up the Buttons on the nanKONTROL2 to light when Activating a rack, turning that lamp off the rack is not active and resetting the lamps on all 24 buttons when the songs are switched.

Thanks, I hope to take you up on that offer. Maybe you remember my trouble trying to demo my Voiceworks setup. The trouble was caused by resetting the audio level on all of my songs to -12dB with an LU meter. When I did the mix down, I forgot to check the Audio/MIDI track alignment in Studio One. The MIDI vocal tracks were set up starting on Ms 1 & the Audio track started on Ms 2. Dumb mistake on my part. :nerd_face:

1 Like

I saw a band called ‘The 3 Larrys’ once upon a time … :grin:

1 Like

I think when they broke up, one of them started a plumbing business around here called “Larry & Sons”. Lots of gigs now, but their career seems to be headed down the drain. :joy:


Hi Doug, can you share more about controlling the nanoKONTROL2 lights - I followed when Brad introduced the feature but haven’t done hands on yet.



I’d be happy to. I have to take my wife down to the hospital for a sleep study this evening. I’ll get something put together when I get back home.

We both use a nanKONTROL2. I use mine to control racks and gain in my setup. I have her nano set up to control 8 Parts (with instruments assigned to those parts) in her Roland Integra-7 sound module.



  1. Open the nanoKONTROL2 editor (with Cantabile closed) and go to “Control/Common” page and be sure that the LED Mode is set to “External”.

Note: I leave the CC assignments on Default (you can always use Control Map in Cantabile’s Filters if you have a conflict.

  1. Save your Set Up to a file and then Transmit the settings to the nanoKONTROL2.

  2. If you haven’t done it yet, set up the nanoKONTROL2 in the MIDI Ports section of Options.

  3. One of the things I have set up in my Songs, is an External Method to determine whether the Racks are Running" or “Suspended”. I also want a visual indicator to show that the Rack is “Running” (LED).

I set these Bindings in the Song, since the Rack Names change.

  1. The example shows the Racks for my B-5 Organ and AmpliTube 5 Leslie. You’ll need a Binding to change between “Run/Suspend” on the Racks and anothe Binding to light the LED. Set them like my example and they’ll Light when the Racks are “Running” and turn Off when the Racks are “Suspended”.

Also, I use the nanoKONTROL2 to control the “GENERAL VOLUME” (Slider) and “REVERB MIX” (Knob) on the B-5 and the “GAIN” (Slider) and “VOLUME” (Knob) on the Leslie.

On my wife’s Rig, I set up 8 Racks (one to Ch. 1 through Ch.8 - PARTS) with the MIDI OUT set to her Roland Integra-7. I have her nanKONTROL2 set up to “RUN/SUSPEND” and control which PART (Instrument) is playing.

This should cover it. If I missed anything (it’s late and I have to get up at 0400 to go back to the hospital to pick her up), let me know.


There are two Dougs and one past tense of dig.


Thanks for the detail on the nanoKONTROL2 lights - I tested a few things succesfully.

My pleasure. :+1: