FR: "Toggle Play/Pause" should start always (also from stop mode)


#1

Actual behaviour:

Press Stop.
Press the hot key for “Control - Toggle Play Pause”: Nothing happens (why not?)
Change current song position (e.g. by clicking somewhere in the Timeline Panel).
Press the hot key for “Control - Toggle Play Pause”: It starts playing (why now?)
Press Stop.
Tigger the binding target “Transport - Play/Pause”: It starts playing (this is what I would expect).

Expected behaviour:

Play/Pause should always start playing - independently of any transport state or position.

Range switching issues
When switching ranges (by either using the drop down menu or a “Media Player #1 - Prev/Next Play Range” binding), behaviour depends on the current play state.
When stopped: Current transport position will always follow the left marker of the range (which is OK for me).
When playing: Current transport position keeps unaffected (why?), unless you swith to a range that is before the current transport position - then transport stops implicitely (why?)
My Suggestion: Always follow the left marker after switching ranges (also while playing). Never implicitely stop.

Edits:

  1. Renamed this topic from “Transport Questions and Suggestions: Different behaviours when stopped/paused/playing”
  2. Cancelled the section concerning ranges, because I’m going to address this in a separate topic.

Additional Comments:

I found that there seem to exist two different states for “Paused” (pause button is orange) and “Stopped” (pause button is grey). Maybe it’s a relict of this experiment: