FR: finer granularity for VST paramater binding


#1

hi @brad ,
at the moment we have 0.00 to 1.00 which covers most needs.
one particular VST parameter that often has a very large range and is important to have it set accurately is ‘delay time’.
it be great to have 0.000 to 1.000 to play with, if it’s not too much of an upheaval to implement?
cheers,
Neil


#2

Difficult to set a parameter at this level of precision in a binding (I assume) when a MIDI controller can only do 0…127.

Or do you want to set the delay to different values directly via state->on load bindings?

If you want that level of precision, have you considered tempo-synced delay? Usually far easier to simply set 1/8, 1/8, dotted eighths - and if needed simply modify the tempo via state?

Just thinking out loud…


#3

it’s more like i’ll use the whole controller range 0-127 to control just a small part of the vst parameter range, say 0.46 to 0.62
some vst parameter like feedback or delay lines within Zebra’s reverb can have dramatic effects within a small range.
if you want your controller’s 0 and 127 to hit very specific parameter values sometimes you need finer control of the max and min.


#4

VST parameters already have much finer precision than two decimal places (32-bit float for VST 2, 64-bit float for VST 3).

Exactly which display value are you referring to (include a screen shot)? It’s probably coming from the plugin itself and outside Cantabile’s control.

Brad


#5

vst%20max%20min


#6

in this instance i’m playing along to the album version of Pink Floyd’s ‘Any Colour You Like’ which has a 1 beat delay with heavy mix and feedback.
the tempo speeds up quite a bit through the song and hence the tape delay time decreases by 60ms or so.


#7

Ah ok. Increased it to 3 decimal places. Will be in the next build which is in the oven now…

btw: this is a display only issue. You can type as many decimal places as supported by the floating point precision and they would have worked… you just can’t see it in the display.

Brad


#8

that’s great, thank you.
i’m on quite an old build, back from April, and it definitely rounds the value to 2dp when you press OK on the dialog box.
will update to a newer build and see if i can get the hidden precision to work.


#9

it’s works great in the latest build, thanks again.