Footswitch to change states


#1

Hi!
I use a standard footswitch to change Song States, but each press moves forward of 2 states. I’ve used this function already and it worked fine, did something change in the latest versions?
What binding to use exactly? I need the CC64 (Sustain pedal) to assign in the Background rack. Thanks.


#2

That’s exactly what I do and it’s still working fine in the latest version. Do you have two bindings picking it up? Try disabling the binding and see if it still advances the patch.

Neil


#3

Yes @Neil_Durant , I’ve more bindings assigned to the same function, but it should not make a problem, it was this way also couple months ago…


#4

What kind of pedal is it? It may be bouncing…


#5

A Bespeco VMP-24. However, testing different pedals… some even worse, a Roland pedal jumps 4 states at once!


#6

Are you using cc 64 to trigger song state change and if not what data cc number do you use from your switch?


#7

Wow… is it possible to revert to an earlier version and verify that it’s somehow software related??


#8

Yes. My footswitch is assigned to CC64


#9

Are you using a binding in background rack? Do you use the pedal for any other task?


#10

@dave_dore Yes it’s in the background rack. That pedal seems assigned to nothing else.


#11

If you press it down and hold it down, does it still result in two Next States? Or is the second one actually happening when you release?

What have you selected in the binding Event column?


#13

That’s right @DannyM, he could try different switch types on the binding.

ms7

Dave


#14

@DannyM yes exactly, one state advances on press, another state advances on release the pedal.

Binding event is “Next State (instant)”.

I’ve used this function on the same keyboard, with the same pedal in the same Background rack on the last 3 tours I had…


#15

@dave_dore thanks a lot but why so complicated now? It worked fine and simply until the tour in December 2016…


#16

Find the solution: now the binding that works correctly for this pedal and/or keyboard is different, it’s “Controller (button)” . Before it was “Controller (no edge button)”.

Don’t know really the difference, but it is what it is… :wink:

Thanks to you all!


#17

Yea Sorry I misunderstood and it was a trip to the weeds I will trash it …:grin:


#18

To explain, Cantabile’s controller binding options are designed to handle different kinds of events that different buttons send…

  • Button - triggers when the value cross from less than 64 to greater than 64. (edge detection)
  • Button (No Edge) - triggers when any non-zero value.

Sounds like your footswitch was configured to send two different values on press/release which would explain why it’s double jumping. I can’t really explain jumping four states unless that controller was pressure sensitive perhaps and sending many cc values.

Best way to check these things is Options -> Diagnostics, turn on Console Logger and Log MIDI In Events. Press the footswitch/controller and see what it’s sending.

Brad