Focusrite Scarlett Solo not recognized in Cantabile 3/4

A while back, after I rebooted my system when Cantabile came back up it was no longer recognizing my Focusrite Scarlett Solo (Gen1) as an “Import Port”. As such, the “song” wouldn’t load, and my VST plugins were no longer working.

I tried upgrading to v4 today, and it’s the same issue. The device is still usable in Windows…I just am not able to run it through Cantabile to add my plugins.

The strange thing is that the UI does report the Focusrite as a device, but there’s not much I can do with it. (see attachment)

I must be doing something wrong. Any assistance is appreciated…

suggest re-installing the ASIO driver for the Focusrite. Windows uses different drivers…

1 Like

Perhaps you plugged it into a different USB port - or Windows assigned it to a different port?
Check your MIDI input ports in the Cantabile Options and see if the Focusrite is now on a different port.

1 Like

I am using 1st gen Focusrite successfully with Cantabile. As suggested, try the latest drivers or reinstall them.

1 Like

I have a problem with my Focusrite Scarlett 2i4 where it is definitely plugged in, but not recognised (even in Device Manager), until you unplug it while the computer is on and replug it - tricky as it is buried in my rack. I am thinking of a small extension lead so I can disconnect/reconnect without having to pull the rack to bits.

Anyway, I soon found the pattern that causes this issue for me. It is doing Windows updates and letting the computer restart after the update.

If I update and shutdown, cut the power to the rack, restore it and then restart, then it is fine.

Not sure why, but it works. It may or may not help you, but worth pointing out.


Thanks, all. I reinstalled the ASIO driver, and switched USB ports (from a hub to right in my laptop’s base station). In Cantabile Options>Audio Engine, it is seeing the device (see attachment). But I am still unable to add it as an input port in the main.

I feel like I must be doing something wrong. Or something changed in the software that non-MIDI devices are now used differently? But all I see in Input Ports are “Main Keyboard” and “Onscreen Keyboard”.

Hi grelenco and Welcome to the Forum!

Can you show a screen shot of your MIDI input port setup for the Main Keyboard? e.g


Hang on - what are you trying to use your Focusrite as? So far, I assumed you wanted to use it as an audio device (since you were pointing at the ASIO status and the Audio Driver setup). But now you talk about Main Keyboard and Onscreen Keyboard - these are MIDI ports!

MIDI is handled separate from audio in Cantabile - the ASIO driver has nothing to do with that. And - as far as I know - the Scarlett Solo doesn’t even have a MIDI port.

So it would really help if we could zoom in on what you are actually trying to do: are you trying to route MIDI to a VST instrument or are you trying to route audio signals through an effect plugin?

If it is the latter, then please post a screen shot of your “Audio Ports” page so we can see better what’s going on.

Also, on your first screen shot, I see the “power switch” (top right) colored bright red. This means that Cantabile can’t start the audio driver for your interface. Is this still the case after re-installing the ASIO drivers for your interface? This would indicate something is still broken with the installation of your audio interface drivers - not much Cantabile can do until this is fixed.



Audio device 100%. My point about the keyboards was that those are the only items showing in the interface as “input ports”, where in the past (before these issues arose) I saw the Focusrite on there as well.

In answer to your question, yes…this is still happening after re-installing the ASIO driver for Focusrite. Windows is totally happy with the drivers…I can access them in other applications just fine.

The strange thing is that Cantabile does see the Focusrite, because it shows up in the “Audio Engine” tab in settings. And clicking the “Control Panel” button there does in fact open up the control panel for the device.

Hi Dave. Thanks for the help.

Here’s the MIDI input port configuration. Although I’m not using any sort of MIDI device on this computer at all…but I’m open to any and all suggestions on how to get the Solo routing through Cantabile again.

OK, then please share a screen shot of your “Audio Ports” settings. Normally, even if your audio interface isn’t starting, you should at least see your input and output ports in the routing view (even if they show up as “disconnected” or “unassigned” in Audio Port settings.

I just tested this with my setup, using the ASIO drivers for an unconnected interface. It shows up with the same “- samples @ -Hz” in the Monitor tab as yours does and gives me a bright red on/off switch, but I still get to see all my input and output ports - they just show up as “unassigned”.

So I’m suspecting something is messed up in your audio port configuration.

Let’s first address this, so please share a screen shot of your Audio Ports settings.

Next we need to see why your interface drivers seem to fail to load - Ideally share your log files here:

  • Tools->Open Settings folder
  • put log.txt and log-previous.txt in a ZIP file
  • post the ZIP file here (simply drag it into the editing window)



Oh, and another thought: if your on/off switch is blinking red, try clicking it once (turns off the audio engine) and then once again (tries to turn the audio engine on again). If something goes wrong, it should show you an error message (which is otherwise suppressed). Please also share this error message

Looks like this for me:


which is logical in my case, since I don’t have the Mackie mixer connected :wink:

Thanks for the assistance…was out of town for a few days and am just catching up now. Here’s my ports settings…all are assigned:

I will reply again with the log files. I can only add one attachment per post.

Hmmm…can’t upload zip files either. I stuck it here:


Thanks for the assistance. Here’s the error message I get:


Yup, there’s definitely something wrong in your interface driver configuration. When I look at your log, it keeps showing that all your inputs and outputs are disabled:

00097841        0   [28328:2]:     CoreEngine - Starting audio driver
00097841        0   [28328:2]:     asio - ASIO Driver: Focusrite USB ASIO
00097841        0   [28328:2]:     asio - Starting on thread 28328...
00097841        0   [28328:2]:     asio - Input Channel #0 - Input 1 - Disabled
00097841        0   [28328:2]:     asio - Input Channel #1 - Input 2 - Disabled
00097841        0   [28328:2]:     asio - Output Channel #0 - Output 1 - Disabled
00097841        0   [28328:2]:     asio - Output Channel #1 - Output 2 - Disabled
00097841        0   [28328:2]:     asio - Creating buffers, count: 0, size: 192
00097841        0   [28328:2]:     asio - Stopped.
00097841        0 ! [28328:0]:     asio - Failed to create buffers - ASE_InvalidParameter (0xfffffc1a)

So when it comes to creating buffers for inputs and outputs, there are none to create (since the inputs and outputs are disabled), and the process fails.

Since I don’t own a Focusrite Scarlett Solo, I won’t be able to help you further, but maybe we have other Focusrite users who are aware of this phenomenon?

One question: are you using this interface also as your standard Windows audio device? Not all drivers are able to share the same device between Windows and audio applications. This could be the reason for the disabled inputs and outputs: it is possible that if Windows is “grabbing” the Focusrite inputs and outputs, they aren’t available for Cantabile and the ASIO driver.

So definitely something to try: make sure to set your Windows audio device (input and output) to something different, and NOT the Focusrite, then try if Cantabile and the ASIO driver work now. Then report back - dead or alive :wink:



1 Like