First load/play of a session

Tags: #<Tag:0x00007f97863209b8>

A problem here after the first loading of a session: first time I play the audio jumps! It’s NOT ready at the first key press. Why? This need to be reviewed because for live performance is very dangerous… and in couple weeks I go on stage!

Attached a screenshot of the recent session that gave me the issue.

Brad can you check it? Thanks!

Also, please, could you give here a quick explanation about the paramters shown in the “Load & Info” area?

  • Load
  • Page faults
  • Running/Loaded racks (not clear, it says 4/4 but in this song I’ve 2 standard racks and the background rack = 3)
  • Objects/Locked Zombies

What do you mean by “the audio jumps” - the volume level jumps? And what do you mean by it not being ready at the first key press? Does the first note get lost?

Some more clarity on what you’re seeing/hearing please!

Neil

It’s something I’ve noticed too, with certain Kontakt libraries (the vintage organs one springs to mind), they don’t play the first note you play… (or the sound triggers late) it’s probably a Kontakt thing, but there you go.

Cheers,

Toaster

2 Likes

The first note/chord gets lost! Exactly as @Toaster noticed too.

It’s like:

  1. load the session (song)
  2. press the first chord
  3. no sound
  4. sound comes after few ms.

It looks like I need to pass through all the sounds I’ll need in the show to be sure that they are played the very first time. So, they will be ready the second time…

It happens also if I move a controller the very first time, for ex. an expression pedal, it makes the audio jumping…

I’ve even created a “LoadUp” session which loads all the plugins and the racks I’ve in the set-list (show) to have them loading faster when I recall the songs. But the very first press/play is still a very problematic issue!

I (and I guess other users with the same issue) would need this issue solved…

Thanks!

Not certain if this affects it or not, but do you have “Pre-Load Set List” checked in Tools?

From the Guide:

PRE-LOADED SET LISTS

In order to improve song switch times you can instruct Cantabile to pre-load all songs and racks used in the set list:

From the Tools menu, choose “Pre-load Set List” to toggle this feature on or off.
Whether to pre-load a set list is stored as a property of the set list, so you can have some set lists pre-load and some load on demand.

Depending on the plugins you’re using, pre-loading a set list may require considerable RAM. You can mitigate this by sharing plugin instances across multiple songs by loading them into racks and using the same rack in each song.

Terry

1 Like

Have you looked at the Cantabile guide on the monitor page? There’s also another guide page describing Load.

The above guides don’t go into detail about page faults, but the simple description is that a page fault occurs when a program tries to access some data from memory that the operating system has swapped out to hard drive. The program then has to wait while the data is loaded from disk, which obviously takes a lot longer than if the data was accessible directly from memory. It’s not a fault in the sense of an error - it’s a normal thing that happens all the time, especially on machines with less RAM. In Cantabile, if you get a large number of page faults on a continuous basis, it might be an indicator that you need more RAM. But it’s not a problem unless it affects Cantabile’s performance, by potentially causing spikes in the Load value, or in the worst case causing clicks/distortion/dropouts.

Regarding Running/Loaded racks, do you have any embedded racks within any of those 3 racks you were expecting it to report?

Neil

1 Like

Does this happen on all plugins, or just certain ones? I notice with Ivory II, the first time I play it after loading a session, there’s a little noticable latency, until I’ve played a few notes. I think this is simply that Ivory streams sample data in off disk and caches it in memory, so until it’s all in RAM there’ll be a little delay of maybe 10-20ms. However in my case I always hear the notes - they’re just a bit late. It’s down to the way some plugins work, and there’s not a lot Cantabile can do about it.

If this is the cause of the problem you’re seeing, and not some odd bug in Cantabile, then I guess the only solution is to identify which plugins have this behaviour, and pre-play them a bit. Don’t you have a sound-check before your shows? I would think that ought to be enough to ensure the samples you require all get loaded, and ready for instant playback.

Neil

1 Like

The first thing I’d check here is bring up the MIDI Monitor and check the notes are getting to the plugin.

ie:

  1. Restart Cantabile and get to the state where you expect this problem to happen.
  2. Right click on the plugin in question and choose “MIDI Monitor”
  3. Play you’re opening chord.

If the monitor shows the MIDI notes but no sounds then this is almost certainly a plugin issue. If not, let me know and I’ll look into it.

Brad

1 Like

I also noticed that problem with Kontakt Vintage Organs. It is Kontakt related, I checked it with another DAW and even with the standalone version of Kontakt. My workaround right now is a little combination of triggers inside my rack which contains vintage organs:

On rack load…

  1. mute audio output
    [delay]
  2. trigger some note ons
    [delay]
  3. trigger same note offs
    [delay]
  4. unmute audio

Right now, this is the only way i get vintage organs ready to play.

2 Likes

Thanks for the info!
Concerning Running/Loaded racks, no embedded racks in the session. 3 racks as said, this is why the calculation looks strange to me …

Thanks Brad, gonna check it too…

Hi Terry thanks for letting me check it, because it was checked time ago (indeed I remember this problem started sometime suddenly… and I could not identify when and why…) and now I see that the option “Pre-load set list” is off! So probably I’ve unchecked it by mistake … gonna try if it solves the issue… thanks

UPDATE: well, the Pre-load set-list does not solve the issue, also it causes the system to be over-charged. And I do always a pre-load manually, indeed , as written already, I created a Pre-load song which loads the racks and plugins more used in the show. So, I guess this does not solve the “first play” issue… thanks anyway.

1 Like

Hi Brad! For info, I can already tell you that it’s not only one plugin making this problem, I can count for sure 4-5 different plugins, I guess it’s not a plugin issue…

Just wondering if all of the errant plugins rely upon loading sample sets? That takes a moment, especially with large sets. Kontakt and Vienna Pro supposedly “drip” in the sample sets, streaming more detailed sample data for different velocities in over time, but I do not own either to be able to test how to optimize those. My Plogue sforzando instruments all take a moment, as they load the entire sample set before they let me get going. (I’m actually pretty new to using sampled instruments… not even a year into those yet.)

Terry

This optimization gets pretty complicated - see this video on optimizing Kontakt!

I would lose my mind if I had to do this for live stuff! :dizzy_face:

Terry

Are you by any chance switching the plugins in question to disabled (the orange light) and experiencing a delay in them turning “green” again upon enabling them via state changes?

Elsewhere, I believe it was @Torsten who was mentioning regarding something else that the best approach was to merely switch on and off the INPUTS to plugins via states (in the top inputs section) rather than disabling/re-enabling the plugins themselves. That eliminates any delay in their appearing when you switch their inputs back on, and allows long tails to continue even between songs (which I think was the topic of thread Torsetn had posted this in).

Terry

Hey @Mistheria
There is a well known phenomena in some sample playback plugins, Kontakt, Halion, etc, where demand on the first play is not met. It’s something to do with ‘charging’ the ram buffers one time to ensure that they are primed.

This is not an issue in a studio situation - but live? Watch out.

I use the Vienna Ensemble thing that Terry has linked to above. I can be using upwards of 70 Kontakts across two machines. There is a ton of RAM and horsepower and it’s all SSD…but… I always run a cue through before printing because of this high probability that not all notes may sound first time through, and it can be easy to miss.

So, what can you do live? You can create a midi file which plays in a muted state. This routine can be performed extremely quickly, and acts as a ‘primer’ for all the notes.

I would be really interested to know if this cures the problem.

@Ade and @terrybritton thanks a lot for your posts and info and suggestions. But, honestly, this issue is something to be approached differently. On Cantabile 2 I never had such a problem.
That workaround can be a temporary solution, but I cannot believe it must work this way, no sorry, it cannot be… There is a problem to solve and a solution to find… I’m sure about it.
Please @brad can you investigate about it?

Btw, I am not using Kontakt in my setlist.

Thanks to all!

1 Like

To clarify it again: I’m talking also about plugins which DO NOT use samples, such as virtual-analog synths, e.g. MPowerSynth (MeldaProduction), OPX-Pro II (SonicProjects), etc.