Drift issue with clock sync for Enso VST

,
Tags: #<Tag:0x00007f97948fa358> #<Tag:0x00007f97948f9d18>

Hey guys, I have a strange issue I’m trying to find a root cause for. I’m using Enso, a looping VST from audio damage:

It’s a really solid looper with a great GUI, easy midi mappings, auto quantize for start/stop and triggers - it’s doing most everything I want it to really well, save for one thing - it only supports one loop within the VST. So, I set up a few instances, mapped them all to different bindings for controllers, and voila - multi channel looping. Or so I thought. I noticed that if I looped something percussive, and looped another percussive beat over it, I started to hear sync drift (it was much harder to hear this on melodic instruments, but over longer periods even there it became apparent). Playing the exact same beat over itself, you can hear on each subsequent loop the harmonic overtone shifting up as the frequency overlap slightly shifts on each beat, and after about 45 seconds the drift was enough that you can hear there is at least 15ms shift or so. So the multiple instances of the VST’s are absolutely drifting a consistent amount, every loop around against the master clock. So far I have tried:

  • vst2 vs vst3
  • stopping and restarting the audio within the VST
  • longer and shorter recorded loops
  • using less additionally loaded plugins

No differences with any - exactly the same presentation, every time. I have reached out to audio damage about this as well.

I also loaded two instances of the plugin into Cubase and tested similarly and over 5 minutes there is no perceivable drift - so this appears to be specific to Cantabile in some way. Thoughts?

Thanks!

Jeff

Update - this is still proving consistent. I ruled out anything retained in the linked rack preset by using new instances - same amount of sync drift. @brad - any ideas what might be going on here that this midi clock sync issue happens in C3 but not in a DAW? It’s worth noting that if this issue weren’t present, the forum questions I have seen on here about looping in C3 on something other than Mobius would have another solid option.

Hi Jeff,

I’m not really sure I’m completely understanding what’s happening here. You say all the plugins are drifting the same amount… so what are they drifting relative to?

I don’t have an answer off hand and I suspect I’ll need to reproduce this to figure out what’s going on. I’ll get in touch with AudioDamage to see if they’re willing to work with me to figure it out.

In the meantime, can you send me a minimal song file with everything configured such that it reproduces the problem.

Also, you mention MIDI Clock… are you using MIDI clock sync or Cantabile’s metronome?

Brad

Hey Brad, thanks for getting back to me. I am using the metronome in Cantabile as a master clock. The plugin can either respect that, or loop against a sample length. Setting up two instances of the plugin, both set to follow the C3 metronome (by setting the lop time to “measure” in each), record one loop in each for a measure, for example a note on each quarter note. The loops will start right on top of each other. They will, however, slowly start to separate. If you leave it long enough, say, 4 minutes, it will separate apart enough that you can hear the individual beats of each note, so probably about 40ms or so of time separation once that happens. Replicating this exact same scenario in my DAW, Cubase 10.5 pro, this does not occur and the loops stay perfectly in sync. So my initial guess is that something may be up with the clock sync arriving exactly on time to the plugins, being exacerbated over time by the looping mechanism maybe? Just thinking out loud. Thanks for offering to look into, and i will send a file and will try to do a screen recording of it happening if thats also helpful. Also - shooting you an email via contact form related to this.

Thanks!

Jeff

Cantabile calculates timing information at the start of each audio cycle and then reports the same time to every plugin so I’m pretty sure all plugins will be getting exactly the same timing from Cantabile.

I’ll have to reproduce this to try and figure it out.

I figured it probably was doing it that way. Interestingly - I just did this as a bare bones single VST instrument into that set of loopers, and the issue is not happening. Which is now making me thing this may be a performance issue taxing the CPU - still odd that they would fall out of sync evenly though, same amount each iteration (which you can tell because with two identical sounds in each looper you can hear the even frequency shift each loop as the harmonic shifts from the slightly more offset waveform). Let me explore that a little bit more before you bother with this - I’ll get back to you. Thanks again!

Jeff

Just a quick update for anyone else wondering about this. I’ve looked into it and as best I can tell at this point this is an issue in the plugin. I’ve reported details to AudioDamage and will post any updates.