Custom key commands not working

controllers
Tags: #<Tag:0x00007f52be5b53e8>

#1

I’m running Version 3589 on Win10.

I just tried to use some of my custom hot keys (e.g. Ctrl+Numpad 6 for ‘Next State Instant’), but the key presses are being ignored. I don’t know which version I was last using when it was working. Default hot keys are fine, but none of the ones I have created of my own.

This is a bit of a problem for me, since I use an Elgato Stream Deck to emulate these hot key combos for Cantabile control.

Is it just me, and/or am I maybe doing something dumb?


#2

Hi @The_Elf,

Could you send me a copy of your settings.json file (locatable via Tools -> Open Settings Folder) (with the custom key bindings created). Also, what international keyboard layout are you using?

Brad


#3

Thanks for the quick response, Brad. Here’s the file: Settings file

I’m using a standard UK laptop keyboard. Here’s a photo: Laptop photo


#4

I don’t want to mess things up if this is under investigation, but I really need to fix this. Is it worth me trying to delete and re-enter my custom hotkeys?


#5

I figured it out.

I had to change my old designations from, for example, ‘Ctrl+7’ to ‘Ctrl+NumPad7’. Then it all began working again.

In the past it worked without the ‘NumPad’ qualification.


#6

Hi @The_Elf

Sorry for the slow turn around on this (been busy). Yes, newer builds of Cantabile distinguish the numpad keys from other keys. This came about as part of keyboard code rework for the osx port.

Brad


#7

I’m still having trouble getting numpad keys to bind to ‘Next/Previous State Instant’. I’ve pretty much given up on these assignments - no time to fix it now.


#8

OK, I’ll check it out.