Curve Controller Filter not saving by State?

So I’m trying to have the Curve enabled on one state and disabled on another. I’ve checked all the state behaviors, both on the rack and the midi routes and everything is enabled. I must be missing something, because it stays in whatever I manually set, enabled or disabled (States are locked now but they were unlocked when attempting to remedy this). Or maybe this is a parameter C3 doesn’t save? I didn’t see a State Behavior for Controller curve, only Velocity. BTW the FCB rack is my FCB 1010 midi footpedal, Thanks for the help!

Hi Tom,

MIDI filters are not affected by state behaviors, the route control section does have state behaviors however . The best you can do I think is have another separate route that has the enabled filter for that state while disabling the other routes you don’t want in that state.


Yep that works. Thanks Dave!