Crash on Renaming a Plugin with a Duplicate Name

If I:

  • paste a plugin into a song, and then
  • rename the new plugin to the same name as another plugin in the same song file,

… Cantabile hangs. I only tried it twice, but Cantabile hung both times …

Cantabile shows this message:

The dialog closes normally when I click [OK], and then Cantabile hangs.

Hoping others will (carefully) try this before alerting Brad … I’d like to make sure there is not something else going on with my particular setup.

Hey Clint,

Straighten me out. What I get from your post is that you tried to name 2 objects in the same song the exact same name. That is not allowed in Cantabile. So why did you call it a crash? Did it crash when you closed the warning box? It just looks like an error box in the picture to me.


Yep, after closing the warning box, C4.153 hung (froze). Mouse was OK and killing the C4 process worked and no reboot needed, but a definite and immediate freeze when I closed the warning box.

If others do not experience this, then I’ll dig deeper and find what scenario causes this (but trying to stay stable for a few days since I’m playing out several times).

OK, didn’t read very well, sorry. Has the crash report gone to Brad?

No problem … I barely read at all!! No crash report that I can tell … the freeze appears to be absolute … like a

while (1) { nop; }

Didn’t want to take Brad’s time until I’m more sure the scenario …

You did the broad diagnostic with console to give clues?

Uhhh … Huh? If you have a pointer to how to set up this diagnostic, I’ll get on it …

check at least the logging boxes below and OK out to song level.

When do the console live logger will start on it’s own window. This gives real time logging and the verbose increases the level of diagnostic detail.

Hopefully it will give a clue. Turn this stuff off when done, it puts a load on the system when engaged.

Worked great. C4.153 still hangs, but it is not exactly a complete freeze. C4 continues to update and respond to MIDI commands (at least from my EC4, which adjusts levels and such). It appears that it is the Plugin Properties window that freezes - cannot be closed and does not respond.

The last few lines of the live log are:

00135820 0 [11436:4]: VST3- EVI-NER (#20) - - setting up process context
00135820 0 [11436:4]: VST3- EVI-NER (#20) - - setting up processing
00135820 0 [11436:4]: VST3- EVI-NER (#20) - - setting plugin active
00135879 59 [11436:4]: VST3- EVI-NER (#20) - - setting plugin processing
00135879 0 [11436:2]: VST3- EVI-NER (#20) - Started
00135940 61 [11436:2]: Finished committing re-route: +6=80, 130ms
00138229 2289 [11436:4]: VST3- EVI-NER (#20) - Using pending plugin view…
00138230 1 [11436:4]: VST3- EVI-NER (#20) - OK
00147287 9057 [11436:2]: Starting route operation: undoable operation

The full log is in this ZIP file: (4.1 KB)

Hi Clint,

I’d forward the log zip file to Brad or put a flag for him to visit this thread. It is definitely his wheel house on this one.


@brad … I’ve gathered some info on what looks like a situation where C4.153 freezes.

Please see this thread so far … the log file is attached as a ZIP file two messages up …

1 Like

Thanks for reporting… will be fixed for the next build.

1 Like

Fixed in 4156 available now.

1 Like