Crash on Disabling an Audio Input Port with Assignments

Cantabile crashes on exit after adding a disabled stereo audio input port with assignments.

The settings.json file seems corrupt (although I cannot see why) to the point where further launches of Cantabile are unstable. Restoring a “lastgood” settings.json cures the problem.

>> Details

Cantabile Performer Build 3665 on Win10x64.

Spent hours overhauling my Ports (to be more generic, work across two systems with different hardware, etc) and then Cantabile crashed on exit. Sigh.

After that, Cantabile would launch, but crashed on Tools => Options. Would also not load .cantabileRecSet files.

I had never backed up my Cantabile config directory, but thankfully there was a settings.lastgood.json file (just discovered that sanity-saving feature!). After rolling back settings.json to that version, Cantabile launched normally and seemed AOK.

I then made incremental changes and found that adding a disabled stereo audio input port and also providing assignments causes the crash on exit. The assignments I’m making are: Left / Right to ADAT 1 and ADAT 2 on an RME Babyface Pro FS.

I also found that disabling an existing, enabled stereo audio input port that has assignments also causes the crash on exit.

There seems to be no problem disabling MIDI ports with assignments … just audio ports.

Here’s another variation: This time I disabled a port that had previously had assignments. I removed the assignments, disabled the port, and Cantabile crashed.

Are the crash reports going to @brad ?

Yes, by the minute. I think he’s gotten six at this point … (at least I’ve sent them … one never knows if they get there …)
Thanks @dave_dore

Hi Clint, sorry things are bumpy but it looks like you found a use case Cantabile can’t handle, yet. Give it a bit and if no response send an email along to him regarding the issue.

Dave

1 Like

A number of upsides: I now understand much better how Cantabile is configured, how to back up configurations, and how to dig through the JSON files …

If this happened Day 1 it would’a been bad. After three months, I really should have learned this by now …

2 Likes

Thanks for reporting… investigating now fixed for next build.

2 Likes

What fantastic news that you found it and fixed it already, @brad - It was happening to me tonight when enabling/disabling my microphone and completely froze the system (so no error reports were sent). This just happened so if you want the logs, just let me know.

Terry

Give 3672 a go… https://www.cantabilesoftware.com/download

1 Like

Works Great! More Fiber! Less Calories!

… did a bit of testing, enabling and disabling various ports and exiting / restarting half a dozen times. No instability, no issues … Life is Good!