Corrupted Rack/plugin/samples in Sforzando?

I’m realizing this may be a problem solely with my Sforzando plugin, or maybe it’s the rack itself, but I’m posting here in case someone has a solution.

I have a rack with 2 instances of Plogue’s Sforzando sample player in it, it’s been working fine for quite some time… at least 2 years. Yesterday all was good, today I got no sound from the rack with a brass section sf2 file. I can play other sf2 and sfz files from that same rack and same plugin (so it’s getting midi, and sforzando sees the notes I’m playing, but still no sound), but so far I’ve found 3 instrument files that won’t play, brass section, EMU Shakuhachi flute, and a sax… the other 30 or so files i have work fine. Interestingly, those 3 files are in 1 song I added a couple weeks ago, but it’s been working until today.

-If I create a new rack or even just add the sforzando plugin by itself, those 3 files and all others work fine.
-If I try to reload that sf2 file onto the same plugin, no sound.
-I have another rack with sofrzando and I get the same problem.
-I tried replacing the rack from my backup from a couple days ago but no change. I really thought that should do it. I haven’t tried replacing the settings.json file yet from the backup, I’m trying that next but I doubt that’s the issue.
-Sforzando uses Aria converted files (converting sf2 to sfz) so I tried removing the file and samples from the converted folder and reloaded the sf2 brass file and converted it anew. No change.

Any ideas would be welcome. I have maybe 70 rack states in that rack and rebuilding could be a nightmare… but I think I’ll go through all those states, find the ones that aren’t working, then recreate jsut those. But that will still take a while. Can I “Replace Plugin”? If I recall correctly that will require some rebuilding too. Or is there another way?


Hi twaw

I had a similiar problem last week after I upgraded to the latest version of Sforzando. No sound out of my existing racks. Routes inside and outside looked ok, midi was being recieved by the rack, etc. I was lucky because my setup is simple and I was reorganizing anyway. I had to reinsert the plugin and it then worked with the new version.

If you have just upgraded Sforzando, you might try to reinstall the older version.

Good luck.

Thanks John… I didn’t update. Think I’ll have to rebuild the rack. I’ve tried a few other sample players but this was the most stable… Until now. Going to have to find a better one I guess.

Just for information, looks like I just had a related problem. I had existing NumaPlayer and Sforzando plugins in a Song and I copy and pasted them into a new Rack. Cleaned up the routes. Midi was being recieved but no sound. Inserted new plugins, no problem. So, maybe it’s not only Sforzando.

Interesting. I created 3 new, separate racks with new instances of Sforzando and some others. My original rack had become bloated and I suspected that the 6 different plugs might be an issue. So far the original issue hasn’t returned, although I still question whether the bloated rack was really the root cause. You may be right but in my case it was solely a sforzando issue. Thanks!