Connecting USB Audio Device

I’ve tried, unsuccessfully, to connect a Peavey USB-P from my laptop to the mixing board. I’m using Asio4all and Cantabile recognizes the USB device but I’m not getting any sound from my laptop. I’ve had to resort to a line out from the headphone out as a Plan B. How should I set up the Audio Ports page. The ports available to me are: HD Audio output 1 & 2; USB Audio DAC 1 & 2
Available drivers are: ASIO4ALL v2; ASIO Direct Full Duplex, Generic low latency ASIO driver, WASAPI OUT - Speakers (Conexant CX 20671 SmartAudio HD), WASAPI OUT - Speakers (2-USB Audio DAC)
I’m also wondering if I can still listen to my headphone output as well as audio going to the USB out. Thanks

Just a guess, but did you open Asio4All, click the advanced button (wrench) icon and ensure that all the audio ports you wish to use are enabled?

Check this screenshot, you’ll want the little blue indicator to be lit for all the audio ports you wish to use.

As far as listening to both outputs, I don’t see why you wouldn’t be able to just add a route that sends audio to both outputs.

You also may have to restart Cantabile after modifying the enabled audio ports.

Hi @RedSurfer

Have you seen this guide. Failing that, the first two videos here might help.