Confused by Midi Routing - Program Number

bindings
Tags: #<Tag:0x00007f0f4c6f2978>

#1

Hi folks,

In the midi routing dialog there is the option
‘Only route when this program number is active’
which defaults to 1.

I can make this default work by setting my midi controller (Oxygen88) program number to 0.0. This allows midi events to pass, and blocks them when I change to any other program number.

However I can’t work out how to set this field in the dialog box to 2 (to correspond with 0.1 on the Oxygen). If I type in ‘2’ it changes to 0.2, and if I type in 1 it changes to 0.1.

Putting in high values has baffled me even more as 227 changes to 1.99, but 228 changed to 1.100.

I’m clearly just misunderstanding something. Any help would be much appreciated. Cheers!


#2

Hi Alastair,

Try setting your Cantabile Formatting system to Zero based and you should get there. Tools>Options>General>Formatting

Dave


#3

Just to clarify, this is how Cantabile formats program numbers. Basically 0.2 means bank 0 program 2.

If you enter a program number > 128 then Cantabile converts it to a bank program number as follows:

  • the bank number is the program number divided by 128,
  • and the program number is the remainder.

When you enter 227 this converts to bank 1 program 99.

As @dave_dore has mentioned you can tweak how Cantabile formats program numbers in Options -> General.


#4

Thanks very much guys - I now have it working! After understanding the way Bank/Program numbers are formatted the one other step I had to take was to change the LSB Bank on my controller to 1 and then back to 0. Before this Cantabile didn’t register that I was indeed on Program 0.1 - so I think I just needed to send the bank change for this to register.

Thanks again,
Alastair