Chargement d'un programme sur le RD2000 par cantabile

bug
Tags: #<Tag:0x00007fb8243c79c0>

#1

Bonjour
Je cherche depuis quelques jours et je vous avoue avoir beaucoup de difficultés.
si quelqu’un a la solution…

je souhaite, au chargement d’une chanson, envoyer a mon clavier externe une commande midi.
Elle doit charger mon programme 1.

Selon la documentation du roland rd2000 il faut d’envoyer une commande : MSB.LSB.PC de type 84.64.1 pour charger mon programme A01

J’ai créé un blinding :

  • Sources : song / event: on load
  • Target : output port rd2000 / event Program banck : 84;64;1

Mais rien ne se passe

J’ai un petit logiciel de monitoring midi, il me confirme que rien n’est envoyé sur le port midi out en direction de mon rd 2000.

ai je fais une erreur …
Si quelqu’un a une solution…

Merci d’avance
Seb


#2

Hi Seb,

(automatic translation below)
first: you need to use periods/points, not semicolons to set your banked program changes: use 84.64.1, not 84;64;1. Using semicolons will alternate between the values, so it will send PC 84, then PC 64, then PC1 - not what you want.

if nothing at all is sent to your keyboard (not even PCs), you’ll need to check if the output port is actually connected to a hardware port in your MIDI settings.

Cheers,

Torsten


il faut utiliser des points, pas des points-virgules, pour définir vos changements de programme en banque : il faut utiliser 84.64.1, pas 84;64;1. en utilisant les points-virgules, les valeurs seront alternées - PC84 puis le PC64 et le PC1.

si rien n’est envoyé à ton clavier (même pas un PC), tu devras vérifier si le port de sortie est effectivement connecté à un port matériel dans tes réglages MIDI.



#3

Merci pour ta réponse rapide…

Alors j’ai fait les modification mais rien ne change.

Le clavier est branché à l’ordinateur avec un câble usb. Est ce que l’output midi n’est pas actif sur l’usb ?

il envoye bien des informations en input mais rien ne semble partir en output

Dans les options j’ai bien activé l’output de mon clavier.

Element peut être important Dans action j’utilise “program change (banked)” qui ne me permet uniquement de modifier “value”

J’en perd mon latin…
Je suis preneur de tout regard complementaire
Merci


#4

J’ai trouver la solution.
Dans le menu / system/ program control Chanel du Roland rd2000 par default le Canal 16 est utilisé pour le contrôle des program.
Il a suffit de le Changer pour que tout rentre dans l’ordre.

un grand merci pour votre regard dans ces moments de difficultés.

Je vais pouvoir profiter pleinement de cantabile