Channel blocking not working?

I have set up the input from my midi controller to be channel 1 only in C3. The controller does send on 4 channels, but as I have it selected as only one in the input section, I would have expected C3 to ignore anything other than 3.Why is C3 allowing the other three channels to go through to the VST selected?

well, it seems I may have discovered the culprit. Above the keys controller is the Korg nanokontrol which is set to omni…but why a controller that is not being touched (and is a slider and knob controller) is allowing multiple channels in from a totally separate controller is a bit weird. Yes both are linked to the same VST, but how this is happening is odd!

Hey Dennis,

Can you post a screen shot of your inputs expanded out?

not sure it would help, I have already described it :slight_smile: keyboard controller in - forced channel 1 to VSTi, korg nanokontrol in OMNI also to VSTi - pretty simple! If I turn off the nanokontrol problem solved. If I force nanokontrol to midi channel 1 problem solved.

It’s just curious that when the nankontrol is set to omni, it causes the keyboard controller 4 channels through to the VSTi, even though THAT controller has a single rX channel of 1

Are you sure that the route connecting the MIDI input port to the plugin is set to only pass channel 1? If it is and you’re getting 4 different channels of MIDI data at the plugin that means something is very broken.

yes definitely Brad checked it several times. Even manually entered channel 1 into the “Same” field below. It is fine if the nanokontrol is disabled or set to ch 1, but if set to omni it allows the second controllers’ (the Numa Nano keyboard controller) four active outs to all go through to the VST even though the Nano input is forced channel 1.

Got to go back to work now but I’ll experiment again later on.


this is an oops, mea culpa really dumb-ass thing to admit to…seems I had accidentally (I have no idea how I did it) set the NanoKrontrol as an alias to the keyboard controller!!! I fixed that and the problem has disappeared …funny that! hahaha!