Cantabile x64 not loading plugins / insert plug-in greyed out


#1

Hi There,

Apologies if this is posted elsewhere, I’ve searched and it’s driving me nuts!

Cantabile x64 launches, scans my Vstplugins, it displays the scanning progress. Go to insert and Plugin is greyed out.

Go to Tools, scan plugin folders (full) and it scans again, finds 17 plugins, scan them sequentially, correctly identifying them as VST2 64bit. Go to insert - Plugin is greyed out.

Open settings folder. Log.txt finds them all, no obvious errors reported and plugin.json contains all of them.

I have a single 32 bit VST, which loads fine under Cantabile x86, and is reported as an error in the x64 plugin.json which all seems fine.

So, everything appears to be working, just no plugins! I’ve configured audio and I can at least get a metronome click, so I assume that’s vaguely working.

It’s driving me nuts, seems so obvious - no immediate error, plugins all read with no errors, but the insert option is always greyed out.


#2

Hi Starblood and Welcome!

Could you post a screen shot of the greyed out plugin info so we cab see where it is happening in the process?

Thanks

Dave


#3

it’s really just the drop down . . . there seems to be no way of loading a plugin, but plugin.json shows them all and categorizes them etc.

Here’s a snippet from plugins.json - there are 17 all like this, no errors - all look like they’re scanning fine? (I appreciate they’re in an x86 directory - but that’s another story! They load fine into Reason & Reaper; and it’s just a directory name)

{
“name”: “Dexed”,
“path”: “C:\Program Files (x86)\VSTPlugins\Digital Suburban_64\Dexed.dll”,
“vendor”: “Digital Suburban”,
“product”: “Digital Suburban”,
“inputChannelCount”: 0,
“outputChannelCount”: 2,
“technology”: “VST2”,
“platform”: “x64”,
“sendsMidi”: true,
“wantsMidi”: true,
“supportsDoublePrecision”: false,
“caps”: “VST2, 0/2, MIDI In, MIDI Out, 32-bit audio only, x64”,
“id”: “44657864”,
“category”: “Synth”,
“modifiedTime”: 1525035502000
},

{
	"name": "ARP ODYSSEY",
	"path": "C:\\Program Files (x86)\\VSTPlugins\\KORG\\ARP ODYSSEY.dll",
	"vendor": "KORG",
	"product": "KORG",
	"inputChannelCount": 0,
	"outputChannelCount": 2,
	"technology": "VST2",
	"platform": "x64",
	"sendsMidi": false,
	"wantsMidi": true,
	"supportsDoublePrecision": false,
	"caps": "VST2, 0\/2, MIDI In, 32-bit audio only, x64",
	"id": "4172704F",
	"category": "Synth",
	"modifiedTime": 1517441903990
},

I dunno if a screenshot is all that helpful - but click on insert and the plugin option is greyed out.


#4

It looks like a bad install or bug. The Songs Tab should only be on the grid view of the Performer version, wierd! You are running the free Lite version correct? Try saving a Song with a name of your choice and see if your view looks different when you restart. It should look like this on an empty song

Normally you would click on Add Object and the vst menu would pop up for you to choose. If the restart doesn’t get it, try re-installing the program and see what happens.

Dave


#5

The x86 version looks like your screenshot.

I’ve re-installed 3 times this evening, using admin rights. No change!

Running a clean build of Windows 10 pro. Reaper & Reason work fine, for all intents and purposes it’s a clean laptop.

The x86 version works perfectly, but I only have one 32 bit plugin, the 32 bit version of Dexed. That loads and plays great. Just the x64 version doesn’t seem to want to play at all!


#6

I’ll place a call out here to @brad, the developer to see if he can help you sort it out. I haven’t seen this problem before, hope we get it corrected …

it looks like this for x64 Lite on my rig

Dave


#7

Reason: from this screen shot it looks like you’ve got the set list grid open. You can’t insert plugins into the set list grid so the command is disabled.

But: you’re running Cantabile Lite which doesn’t have set list grid. I’m guessing you had the set list grid visible just before switching to license from Performer back to Lite and Cantabile has incorrectly reshown the set list grid panel.

Fix: click in the big blank area and press Escape.

Brad


#8

Brad,

I’m grateful beyond words! Yup, that fixed it.

Thankyou so much for the quick response! That’s amazing support in this day and age :slight_smile: