Cantabile suddenly transpose a just a specific sub-session

Tags: #<Tag:0x00007f978af1c6a0> #<Tag:0x00007f978af1c5d8>

Hi everyone, I’m new in this community. I’ve been using Cantabile since 2019 and I love it, It turns out that Cantabile suddenly transposes a specific rack. I’m playing, and I switch to a sub-session, and randomly I don’t know why, that rack gets transposed. However, in the program interface, it doesn’t show as transposed or does it indicate that there’s anything transposed; it’s the audio. Initially, I thought it was a specific plug-in, but it’s not. Does anybody have this problem?

Hi Christian and Welcome to the forum! :slight_smile:

It sounds like you have a dual route transpose problem. It is caused by having dual route transpositions, one at song level and one at rack level. To prevent the dual transpose you need to have the “Ignore Global Transpose Settings” box checked in the rack’s input routes using the MIDI route setting dialog box inside your racks. This sets things so that the global transpose at song level works properly on the rack input routes. So checked in the rack routes but unchecked on the song routes should fix it. Just go back to the bad rack and check for this check-box’s settings. Hope this helps. If not maybe post your song and rack where the issue is and we can help figure it out.

1 Like

Hi @cceronh

Dave’s comment is valid and you should definitely double check what he describes.

Failing that however, you can diagnose this using the MIDI monitor - start at the MIDI input port in the monitor panel (View menu -> Side Panel -> Monitor), right click on it and choose “MIDI Monitor” and check if the notes are transposed there.

Next move to the route connecting your MIDI device to the rack/plugin etc…again, right click and choose MIDI Monitor and see if the notes are transposed.

Repeat this along all routes to the target location where the notes are wrong.

Once you’ve narrowed down where the notes become transposed it should be pretty easy to figure out why.

Also, some plugins have built-in transpose feature - maybe you’ve got a state saved with plugin specific transpose saved.


1 Like

Yes, a series of midi routes would become cumulatively transposed; a “-0.1” through four midi routes before the VSTi might cause a surprise when the VSTi is playing “-0.4” transpose notes lower. Three of the four midi routes must be checked as “Ignore Global Transpose Settings.” Which brings me to my point…

Is there a way to check all “Ignore Global Transpose Settings” by default for every midi route to allow unchecking the few that actually need to be transposed by exception (most likely the route immediately before the VSTi)?

Once upon a time, I was going to transpose a set list down 1/2 a step, so I tried the global transpose function. Of course, by the time the the midi note got to the VSTi, it was way lower than expected IF any of the previous note specific midi filters worked at all.

In my songs (an probably other users), there are so many midi routes snaking all over the place, the “Ignore Global Transpose Settings” might be better served as the default condition. Or provide a method to swap “Ignore” or “Transpose” as default.

Thank you all for your kindly responses. I’ll definitely try all of your solutions. I’m glad to be part of this beautiful community and find people who are just like me with this fabulous software. :smiley: