Cantabile stops receiving MIDI

Hi, I’m running Cantabile Performer V4.0 Build 4052 on a fairly high spec gaming laptop but am experiencing an issue where sometimes Cantabile will stop receiving all MIDI. I have a Roland Juno Stage keyboard and Akai MPK Mini connected (inc. sustain pedal, footswitch for advancing states and a volume pedal) and they will work fine for a short period of time (usually 10-30mins), but then the MIDI signal will stop being received by Cantabile. Closing and re-opening the software fixes the problem and it doesn’t seem to then recur until I next boot up the laptop.

Any thoughts/ideas what may be causing this please?

Check GlitchFree and setup your laptop per suggestions.

Sounds like Windows Power Options may be shutting down something. I have no idea what. But could be other items discussed in GlitchFree.

Thanks for the response! I’ll have a look through it although I’m not experiencing any audio glitches and as this is an intermittent problem that doesn’t always occur, I wonder if that means it won’t be down to Windows power settings?

I had a similar problem, and like you, it seemed to be related to Cantabile because I could usually fix it by restarting the program. But, guess what? It’s actually a problem with USB and power management. Next time that it happens, instead of exiting and restarting Cantabile, try just turning the USB device off and on; or unplug it, if line powered. It fixes things with my Studiologic keyboard 100% of the time.


There are other facets of audio PCs that are discussed in GlitchFree such as screen savers, CPU core parking, USB/PCI busses powering down, Hard Drive indexing, scheduled tasks, background tasks, etc.

Another vote for GlitchFree … it’s a real eye-opener. … and welcome to the group @MdMatty!

I’ve run through the glitch free doc and made all the recommended changes but am still getting the issue unfortunately. I found that pressing the ‘power button’ in the top right then pressing it again does resolve the issue, but pressing the ‘all sounds off’ button doesn’t.

My setup is a Komplete Audio 6 interface (which does sometimes make a horrible loud 1sec buzz when opening or closing Cantabile, or when closing the settings window - not sure if that’s related), with my Roland RD300NX plugged into it via 5-pin MIDI.

Hi @MdMatty,
unfortunately I can’t offer a solution. However, I can suggest a brief checklist in order to better understand the problem.

  1. does the laptop actually receive MIDI mesagges when Cantabile doesn’t see them? You could check this using a midi monitor app (I use MidiOX but I am sure there are others). In this way you can check if it is a Cantabile or a laptop problem. If MIDI messages are seen by MidiOX but not by Cantabile, then it is probably a Cantabile problem.

  2. are MIDI messages arriving in Cantabile but they are ignored? You could check this using the MIDI Monitor capabilities of Cantabile and/or the green “leds” which light up when MIDI is received from a port. If MIDI is ignored, it could be a problem with routing or with the plugin which should produce sound in Cantabile (on that respect, it is interesting that the problem is solved by switching off and on the audio engine (power button in the top right corner).


Hi Matt and Welcome to the forum!

It sounds like either an under powered audio / midi interface, a hardware issue with the interface box or hardware driver issues.

Do you have access to a different interface to see if that is the case? Also I think that the 300NX has USB MIDI. Have you tried using that connection instead of the DIN MIDI through the Komplete 6? It also might help you track down the cause if we can rule out the hardware as a possible culprit.

I had a Komplete One and it sometimes buzzed for a few secs too when I started Cantabile. I always thought it was the old driver but retired it a while back.

Hope you get it sorted out! :slight_smile:



Thanks again for all the replies!

I’ve done a bit more debugging based on the suggestions. I had already tried using the keyboard’s usb output rather than the MIDI cable but still had the issue.

I installed MIDI Ox and when the problem occurred, that showed the MIDI signal was still coming into the laptop ok.

Please see attached image - when the issue occurred, the ‘input port’ green light at the top of the routing window was still showing signal when I played but the green lights under ‘main keyboard’ and all the level meters didn’t respond. Does this help to narrow it down?

Hi @MdMatty,

could you show us an image of the MIDI ports configuration in Tools - > Options - > MIDI Ports?
In particular, I am wondering about the association of “Main Keyboard” to the hardware port (before and after the problem shows up).


Sorry for the slow reply here. I switched to a different audio interface for a show week last week and it was much more stable. I did notice the issue happen once while I was warming up but it recovered itself within a few seconds (this self- recovery had never happened before with the Komplete interface connected).

I’ve since tried to recreate the problem at home so I could get a full video capture of it but haven’t been able to reproduce it unfortunately. I will try again but at the moment I don’t have any further information.

I’ve had something similar - started about a week before Xmas that Cantabile, in a soundcheck, no longer received MIDI from my Keylab MKII. Reset of the keybd fixed it then - but became more often - actually had to reboot in the mlddle of a show (theater, not a concert, fortunately) like a month ago. Turned out to be a worn out USB cable … replaced it and no more issues since.

Worn out USB cable
Windows power options
Bad USB hub (if used)
Bad driver for a MIDI controller

And to be 100% that MIDI is coming in, also test with virtual cables + a utility such as MIDI OX or Pocket MIDI .

Hi Jack, thanks for the response. I did install MIDI Ox and it confirmed that MIDI signal was still coming into the laptop. I tried different cables and different keyboards and still had the issue. I also ran through the ‘glitch freeI’ book and updated all the power options.

I recently acquired a MacBook so I’m going to give MainStage a go and see if that proves to be more stable.

I have always avoided Apple products because of their unreasonable price. I’d also steer clear from Mainstage (maybe that’s just me). Anyways, from what I read those M1/M2 chips proved to be really well, but man, not for my pocket.