Cantabile filtering out MIDI clock?


#1

First time here, relative newb to Cantabile, so might be just something I’m not figuring out!

I’m mostly using Cantabile as an audio and MIDI router for my hybrid setup with two Elektron boxes. Everything worked perfectly until I tried to get my Octatrack to control the Analog Four. Transport is getting through fine, but the A4 is not receiving clock. I’m sure it’s about Cantabile and not my setup since I can route MIDI fine using MIDI-OX. So using Cantabile + MIDI-OX works but is obviously more clunky than just using one app.

I get that MIDI sync is a feature for the Performer edition, but surely lower-tier versions shouldn’t actively filter out MIDI data when routing between devices?


#2

Performer !! : Dialog Tools > Options


#3

Yeah like I said, I realize MIDI sync is a Performer feature. Seems a bit silly to pay 130$ so that Cantabile doesn’t filter out clock messages from MIDI going between devices though? I guess I’ll have to keep using MIDI-OX.


#4

If you do feel that sync would be the only benefit you would derive from the upgrade to Performer, then indeed MidiOx is a winner of a solution.

Terry


#5

You’re right, Cantabile does filter out MIDI clock in this case but it’s not an intentional restriction. Internally to Cantabile, MIDI clock is handled through a completely separate mechanism to regular MIDI routing and that essentially suppresses those events before they get routed.

Interesting that nobody has ever bought this up before, I could probably fix this for ports where MIDI clock is disabled (ie: all ports in Solo/Lite). Leave it with me.

Brad


#6

Thanks for the quick reply and glad to hear it’s going to be fixed :slight_smile:

Apart from this bug, Cantabile works great as an audio & MIDI router & recorder btw, I much prefer it to other alternatives I have tried.


#7

Build 3588 addresses this…

  • You need to explicitly enable it on a per MIDI port bases. Go to Options -> MIDI Ports -> Double click the MIDI port you want to get MIDI clock and you’ll see a new option at the bottom “Route MIDI Clock” turn it on. (see screen shot below)
  • Since it’s routed like any other MIDI event as part of audio cycle processing passing through to another device will delay it by the length of the audio cycle. (ie: buffer size / sample rate)
  • The MIDI Monitor has been updated to better log MIDI clock related messages, including new setting to hide them
  • The Suppress Events MIDI Events has also been updated with a new option to suppress MIDI clock related events.
  • All MIDI activity indicators have been updates to glow a dim green when receiving MIDI clock related events and/or MIDI Sense events. Other MIDI events will light them up in the usual bright green.

Let me know if any problems :slight_smile:


#8

Please, can you explain the difference between setting MIDI-Clock in Options or Route MIDI Clock in MIDI Input port?

i’am a little bit confused :crazy_face:


#9

Normally (when MIDI clock sync is selected as the master transport) Cantabile filters out MIDI clock related messages and feeds them into the Audio Engines internal time keeping - the timing that’s reported to plugins so they can sync themselves. ie: Cantabile steals these messages and uses them for time keeping aka “syncing”.

With this new option, Cantabile still looks at these messages but also forwards them through the regular MIDI routing mechanism… which primarily means you can forward them on to other external MIDI Devices.

The reason for normally filtering them out, is it reduces an often fairly busy stream of MIDI events that 99.9% of usage scenarios aren’t interested in anyway.