Cantabile doesn't find .NET

Newbie here (but not to VSTs and such). I downloaded and installed the demo version today on my Win11 laptop. Everything seemed to work fine, except:

  • Twice during the installation process, I was notified that Cantabile needs .NET, and asked if I wanted to download it. I said Yes both times, but nothing seemed to happen (no further downloads or popups).
  • After installation, running the program shows the same message. Whether I say Yes or No, the prompt closes and nothing else happens.
  • I check my installed programs, and I already have .NET 6.0.9 x64 (and 5.0.8 x86) installed. I even did a Repair on .NET – couldn’t hurt – even though other installed programs are already using it. Nothing changed.
  • I rebooted Windows. No difference.

What am I doing wrong?


Solved my own problem. In case it’s useful to someone else …

Cantabile doesn’t seem to recognize .NET 6.0. I had .NET 6.0 installed for x64, and 5.0 for x86 (from some legacy need, I guess). I found that Cantable 4 would open in 32-bit, but not 64-bit.

  • I uninstalled every version of .NET on my PC, and rebooted.
  • Then I installed the latest versions of both the x86 and x64 .NET desktop runtime (6.0.9). Cantabile would no longer open in either program mode.
  • Added .NET 5.0.17 x86 and x64 to the PC. Now, Cantabile opens in either mode. :grinning:

Theoretically, .NET 6.0 should be a superset of 5.0, but this isn’t the first time I’ve needed multiple generations of a runtime library to make everyone happy. .NET 5.0 is unsupported at this point, so if the Cantabile staff reads this, you might want to look into the problem.


1 Like

Hi @drawbars,

welcome to the community. I am glad you solved your problem.
Maybe @brad, Cantabile’s developer, would be interested to hear about it.

All the best,

Thanks for the info. How does one contact Brad? Just through the normal support email? I don’t see any link for a DM, unless I’m just missing it.


Well, I have actually summoned him by writing @brad in my reply to you. :wink:


Edit: That just means that he will be notified about this thread. Then we just have to wait for him to have the time to have a look at it.

Actually there is a way to send private messages. Click on your profile icon on the top right and then on the envelope icon. You get to a page where you can click “New message”. You write something like @drawbars in the “Add user” line as you would do with the “To:” field in an email software.


That doesn’t seem available to me, probably as a newbie. I can get to the Messages by clicking the envelope, but there’s no New Message button or link. I just sent the whole report to by regular email.


Oh, you’re probably right and I had forgotten about it. Sorry about that. :sweat_smile:

Couldn’t Resist!


I support a bunch of apps that say they’re going to install .Net but land me on a page that doesn’t have the links.

I go to this page
Download .NET 5.0 (Linux, macOS, and Windows) (

Then find the .NET Desktop Runtime x64 link on the page:


1 Like

Yeah, I went to a different site, but ended up at the same end result. Installing .NET 5.x runtime on top of .NET 6.x works for both Cantabile and other apps I use.

In principle, having two versions of .NET installed on the same PC is OK – I’ve seen the same situation with C++ runtime libraries and such – but there might come a point where a security flaw is found in .NET 5.x, and since MS doesn’t support it anymore, they won’t be fixing it. So long term, getting Cantabile to work with .NET 6.x is the right path. I talked to Brad, and he’s going to look at what’s going on. I’ll bet that there will be a patch at some point.


I know back when I was developing oil and gas software on .Net the “major” version was a compile option in Visual Studio. Not sure if its still that way or not.

Hi @brad,

I’m trying to install latest version of C4 (4062) on a new Windows 11 laptop and I’m getting same issue with .NET not installing.

Thanks - David

I get occasional reports of this and I’m not sure exactly what the issue is, but I’ll take another look at it next week.

In the meantime, it can be fixed by manually installing .NET as described here:

Note: You need to install both the .x86 and x64 versions for the Cantabile installer to proceed.


Interesting, I only installed the x64 version and was able to run Cantabile after that. It seems that the C4 installer completed, but the error was occurring again when I tried to run Cantabile. I installed

and then C4 started correctly.

Installing just the x64 edition will let Cantabile run, but next time you run the installer it will notice that the x86 version of .NET is not installed and try to install it again.

ie: you’ll get messages about this from the installer until both x86 and x64 are installed.