Cantabile does not like Document folder on another Drive

bug
Tags: #<Tag:0x00007f6af1535aa8>

#1

Hi, Brad

Today I did a backup and moved my Documents folder from C: to E: as I was running out of space on C: and moving my /Users/Derek/Documents folder (via the Explorer location move function) got me some much needed space back until I can move to a larger main SSD drive for C: (programs) and D (Samples).

Anyhow, when I started up Cantabile after doing this, it crashed (I’ve sent the crash reports). I am guessing because it could not find the last set list. When I restarted with the “Do Not Load Last Song Option” it started fine, and I could then load set lists and songs as normal once I navigated to them in their new location

However, Cantabile is not finding the new location of my Documents folder and is creating a new Documents folder in the old location on C: and of course it defaults to this on File/Open not the new location

It’s not the end of the world, but it would be nice for Cantabile to recognise the new location (e.g. like applications like WordPad do)


#2

Not sure about auto recognition but did you check the C♪3 File Locations in options, you can set things there. The way I redirected my Documents folder was to use the location option in propertiies and then moving the files after.


#3

Hi, Dave

Doh, I did not think about checking Cantabile’s options for the default location!

I did redirect the location of my documents folder via the property dialog as you show above.

I’ve found a couple of other things that don’t like it. Synapse Audio’s Dune is one of them. Although it sounds like if I reinstall it, it might then pick it up (or I could check the registry to see if it is set there)