Cantabile crashing when application loses window focus

Recently upgraded PC, installed cantabile and moved my presets over and re-installed all my plugs.

All of my old songs work fine. My setup is not particularly complex: used for vocal chains only.

New songs I have created have the annoying habit of causing Cantabile to crash as soon as Cantabile loses window focus (clicking anywhere outside the application). Sometimes re-saving the song, or switching to a working song and back to one of my newly created songs will prevent the crash from happening but it’s not a reliable solution (works 1 in 10 times or sth like that). The new songs are all using the same plugs as the old ones. They are also using the same general Cantabile config but I’m at a loss as to why certain songs virtually always cause a crash.

Also, Cantabile crashes on exit about 30% of the time.

I’m on Windows 10 Home (latest) and this issue has persisted since re-install and across the last two major Win10 versions.

Don’t know if this is the somewhat same problem when I upgraded my laptop. It was attributed to my graphic card settings. I disabled the default “high contrast” in my Personalize screen settings. The high contrast settings didn’t play well with certain plugs. It took 6 months to finally find it. It runs smoothly now. Just an idea. Hopefully that works for you.

Regards

Corky

1 Like

An interesting idea, but I think if that were the issue, if I even had something personalized, then I would be seeing this issue across all my songs and not just the ones that I’ve created on this new machine.

Edit: I double checked, only personalization I have done is to change the desktop wallpaper. Also, I don’t even have to open any plugs. If I load up a song and immediately click anywhere outside the application, it crashes.

Again, this is similar to what I was experiencing. The graphic card used the high contrast setting as default. I changed nothing until I realized graphic settings were the culprit. That’s when I fixed it. Not saying that is your problem…just letting you know what I ran into.

Are you using the same Cantabile version, as was on your older machine? Sometimes, an upgrade can act differently with your older version, but rarely. Moving to a newer machine can be a bitch, especially if you don’t use the same exact locations for everything, as on the older machine. It took me quite awhile to line things out.
Have you followed @brad’s advice in “Glitch Free”, and Derek Cook’s “Cantabile Guide” free on site? Very good advise when setting up a new machine, and will save you many headaches.
I personally do not install Windows updates.
Everytime I did in the past, something went wrong. The only reason I would even consider being online, would be to update a vst, or iLok. Most of Win updates are security related, so I am not missing anything I really need. I have another machine for internet use only.
Sorry if none of this helps. Hopefully, one of the resident gurus will chime in with better ideas.

Regards

Corky

Hey IntrebuloN,

Did you send your crash report to @brad? The log file may have some clues, but a lot in there only Brad understands. To find the files, go to Tools->Options and there is a button near the top “Open Settings Folder” that will open the directory your files are in. Sometimes I have a problem sending crash reports because the files are too large. Brad has a Dropbox for such an occasion. Or, use your preferred cloud provider and send Brad a link. He tries to get to them fairly quickly. He will for sure has an answer.

Meanwhile, @Corky’s advise about the graphics card is something to look into. As far as Windows updates, I haven’t had a problem since the debacle Microsquish had a few years ago. It’s been pretty smooth. I install updates on my Studio machine almost immediately, then my Live machine after C3 is proven out on my Studio machine. I’m running the latest Windows and the Stable C3. I’ll update C3 to the latest after practice tomorrow.

2 Likes

Hi @IntrebuloN,

I just checked for crash reports from you but haven’t seen anything since early March. Crash reports will be the best way to get a handle on this so do as @RackedBrain described above and send them through and I’ll check them.

To upload, zip them together and upload here.

Brad

2 Likes

@Corky I will look these items up and work through them as I’m able to find the time. Thank you.

@RackedBrain @brad Yes, I have not sent the report in some time. I’ll make sure to send the next few when I’m next using the application: the issue is easy to reproduce.

I did peruse a few logs and nothing jumped out at me. It just appeared to decide to unload everything and shut down (without saving changes to the current song, if any were made). When it crashes and I fire it back up, it loads the previous song that was up when it last shut down gracefully.

High contrast is off in Windows. This was a platform upgrade along with going from Windows 7 to Windows 10 but the GPU I carried over for now, so same GPU but different driver package. I do not see anything in the NVidia panel regarding high contrast outside of 3D application settings and I have some colour tweaks there in conjunction with the colour profiles from the respective monitor manufacturers. As part of my troubleshooting I disabled GPU acceleration in Cantabile and it made no noticeable difference.

What is weird is I can get around the issue by loading an old song, saving it, loading a new one created on this machine, saving it, then and old one again and saving it before loading any song of my choice and having it work correctly. This is probably related to my earlier issue of the application crashing on exit (with or without save confirmation dialog for the current song). That started happening immediately after a clean install of cantabile without creating or loading any songs at all. Was one of the first things I set up after I got Win 10 up to date and my drivers all installed.

I also went from Win 7 to Win 10 Pro. The setting on the graphics was at Personalize>Screen Settings. Repeating…it may not have a thing to do with graphics…just similar to my problem.
Since you are able to recreate the crash, it is best to let it crash, and send the report to @brad. That would save a lot of time and misery in solving the problem.

Corky

Ping me when you’ve sent the crash report and I’ll immediately take a look at it.

fwiw: I’ve always found installations of Win 10 upgraded from Win 7 to be less stable than clean installs. That’s probably not what’s causing this, but something to be aware of.

1 Like

@brad Most recent report sent is with regards to the issue in question. There is also a previous, recent report related to the crash on exit. They may be related or stem from the same issue and maybe some info in it will be helpful.

By upgrade I meant the machine, Win10 was a clean install from genuine media to a brand new clean SSD. I backed up files to my old OS HDD before teardown and installed it as a secondary after Win10 installation and updates were completed in the new machine.

I do not have “Screen Settings” in Personalize. I’m on Win10 Home. There maybe be a feature difference.

Here is the High Contrast page:

That’s fine. Turn High Contrast off, reboot, and see if it helps. If not, back to the search. Recreate a crash…send it to @brad.