Cantabile crashes with M-Audio USB ASIO driver

Tags: #<Tag:0x00007f977c7edf90>

Cantabile Solo 4063 x86
OS: Windows 10
USB mic: M-Audio Producer USB

When I start Cantabile a dialog pops up:
Title: M-Audio USB ASIO driver
Message: The ASIO sample rate is not support by one of the USB interfaces! Please check your sync settings in the Control Panel.

There are no sync settings in the M-Audio Producer control panel. The sample rate is set at 44.1. I can’t do anything in Cantabile, even change the audio engine settings, as it just crashes.

Hi @mks,

just a few hints for debugging.

  1. after a crash, Cantabile should show a dialog box with (among the others) the option “Do not start audio engine”. If you are able to start Cantabile that way, you can check the settings in Cantabile and see if a not compatibile sampling rate has been set there

  2. if the dialog box is not shown, there is still the option to use the command line. you should create a shortcut on the desktop as explained here

However, instead of /config:“somename” you should write /dontstartengine, which should obtain the same results as in 1)

  1. you could look for the Cantabile settings file (settings.json) and open it in a text editor. Then search the file for the string:
    In my settings file, I have an entry for each driver I have used. For each entry, there are a “sampleRate” and a “bufferSize” entry which you could check in troubleshooting your problem.

The settings.json file should be located into your user folder, in
AppData\Local\Topten Software\ Cantabile 4.0 (XXX)
(XXX, on my system, is x64…probably it will be x86 on yours…not sure about it).

Hope this helps,

P.S. Once you are in the settings folder, also have a look at the content of log.txt and log-previous.txt. They are Cantabile log files and they could contain some hint about the reason of the crash.