Cantabile crashes when trying to run audio engine


#1

Hello Community,

Didn’t have this problem before, everything was fine. Now I do and I’ve no clue as to why.

I use a Zoom UAC 2 audio interface and windows 10. Every time I start Cantabile it just crashes when trying to run the audio engine. When I start cantabile and have it not start the audio engine it doesn’t crash.

Any ideas?

Kind regards,

Ruben Stolp


#2

Hi.

First obvious question is, has anything changed on your system? Windows update? New device drivers?

Second question is can you roll back to a Windows Restore point or a recent backup? Best practice is to backup regularly (do a complete disk image), especially when you have a known good baseline. Also set a restore point and do a disk image before adding new software.

Finally if Cantabile is crashing, have you sent the crash dumps to Brad?


#3

Also, have you tried running any other apps with the audio hardware?


#4

Hey @RubenStolp

I just tracked down a couple of your crash reports. Looks to me like the audio driver is having problems - it’s making reset requests to the host and failing to restart which is the causing other downstream issues with Cantabile.

A couple of suggestions:

  1. Check the connections between the device and your computer and perhaps try a different USB cable.
  2. Make sure you’ve got the latest drivers for the device installed.
  3. Try turning on “Ignore ASIO Reset Requests” in Options -> Diagnostics:

image

Let me know if the problem persists.

Brad


#5

Thanks for the replies so far,

Something did change in my system, yes. My laptop’s screen broke so I went to the store at which I bought it initially to get it repaired, and in the process I got an offer I couldn’t refuse. An upgrade to an 8th gen i7 for not so much money. I accepted the offer and I have my laptop back now. It’s really fast (30% faster in theory). But this problem started once I had it back. Not the first time booting, so not immediately, though.

A new CPU also means a new motherboard so it needs different drivers for things, all of which I downloaded and installed yesterday, in the hopes of resolving this problem. It did seem to work, but this morning it’s just doing the same thing again. It seems that after a while of tinkering and my laptop just being on, the problem is gone, but I can’t find a fixed set of actions or circumstances in which the audio driver doesn’t crash cantabile, and I need everything up and running immediately for gigging obviously. It’s also sort of annoying that it works at a certain point because then I can’t try and solve the problem indefinitely anymore.

@brad I turned the Asio reset off, and then Cantabile doesn’t crash but the audio driver just won’t initialize. Thanks for looking them up btw! I tried installing the latest version of Cantabile, no result. I tried reinstalling the Zoom UAC-2 driver, no result.

@Ade Turning off the internal soundcard doesn’t help. Actually, turning on the Mixer software that is supplied with the Zoom UAC 2 helps in some instances to get it to respond normally. But this software is also glitchy. The guys at Zoom need to update the Zoom I think, especially with windows 10.

@Derek Restore point is not an option due to different internals. And yes I’ve sent crash reports.

So as of yet I’ve not found a solution. I think reinstalling windows 10 might be an idea, that somethings’ iffy with the new internals and only new drivers or something. But then I’ll have to reinstall all my software which I really don’t feel like doing, although I have the time because I’m on holiday.

Last but not not least at all, it works just frickin’ fine on a USB 2.0 port. But I’ve tried reinstalling the USB 3.0 drivers, no luck.


#6

Okay, reinstalling the driver again has seemed to work after one restart. -.- I don’t like elusive and finnicky problems.


#7

I had a similar problem after a windows update with my RME cards on both my laptop and desktop machines.

I found that the only thing that worked for me was to go into Device Manager with the cards plugged in and remove the device. Then re-install the drivers. It didn’t work just by re-installing the driver without first removing the device using device manager.

Not sure if this will fix your issue but it worked for me…

Pierce


#8

@Toaster If the problem persists I will try that thank you!


#9

@Toaster Okay, after a later reboot it started acting up again. Removed the devices from the device manager while plugged in. Reinstalled driver afterwards. Working for the moment. Wondering when this will end :stuck_out_tongue:


#10

@RubenStolp is the driver misbehaving in other apps too or just Cantabile?


#11

Specifically, have you tried running Reaper or another DAW with your soundcard?


#12

Have you tried running it with ASIO4ALL. Wouldn’t be the first time it out performs manufacturer provided drivers and might at least provide a stop gap until Zoom can fix it.


#13

@Ade @brad I’ve tried Gigperformer today and as expected it has the same issues. Since USB 2.0 ports are working just fine with the Zoom it must be one of two things, specific Zoom behaviour towards USB 3.0 ports that are on an 8th gen Intel related Mobo or something is amiss driver-wise which can only be resolved by reinstalling windows 10. I hope it’s the latter and I will reinstall today. I’ve contacted Zoom about this as well yesterday. But since it’s just working fine with USB 2.0 I don’t think it’s Zoom.

@brad The Zoom is quite a fast little bugger, and ASIO4All doesn’t outperform or equal it in my previous tests.

I will reinstall and report


#14

Okay, I’ve reinstalled Windows. Quite a bit of effort. Still the same error. Now it’s up to Zoom. I hope they reply to my message. In the meantime I guess I’ll try and use the usb 2.0 port and see if that impacts latency a lot. I’ll keep trying things. I’ve sent an e-mail to the UK office for Zoom. Pretty damn shitty driver support if you ask me.

Now onto installing Keyscape (which takes hours) and every other damn VST I own, for nothing -.-

Edit: I contacted a service center nearby (Germany) and they’ve forwarded my laptop’s specs to the japanese engineers. Wonder what they’ll say.


#15

Hi, this is “not uncommon”

My MOTU MIDIEXPRESS 128 in my home studio cannot go into a USB 3 port otherwise you get a shedload of hanging notes. It is rock solid and fine in a USB 2 Port

My old Focusrite Saphhire Diamond 6 would do something bizarre in a USB 3 port on my old gig laptop. I never got to the bottom of it. But for some reason when it was in a USB 3 port and I exited Cantabile 2, Cantabile would never quit properly - the UI would go, but you could still see the process in Task Manager. If you tried to restart Cantabile in this condition the computer would hang. I had to label my ports and leads to ensure the right connection.

From memory my USB WIFI dongle on my DAW port does not like USB3 either.

I can only surmise it is a chip set compatibility problem, as I know somebody who’s MOUT MIDI Express works fine in his computer. If you put a USB 2 Powered hub in between such devices, the problem seems to go away.

As long as your set the device settings correctly, you should not see any extra latency, as USB2 is claimed to have enough bandwidth for multichannel audio. For this reason, Focusrite do not yet ( I believe, unless it has changed) have USB 3 interfaces.


#16

@Derek Yes USB 3.0 Always seems to have its peculiarities! I’ve some experience with that as well. Thing is, it always worked fine with USB 3.0 up untill now. The zoom UAC-2 is made for USB 3.0 so it would be a pity to not use it’s potential. Haven’t gotten around to testing 2.0 and it’s latency, still installing Keyscape. It’s laughable, the install time. I guess they did that on purpose so that It’s hard to go around installing it everywhere. Or something… I hope Zoom HQ in Japan can fix this. And in the meantime, I think I once had it in a 2.0 port by accident and didn’t notice untill I litterally saw it. So I don’t think there’s a problem. I do not like having a product however, that I cannot use to it’s full potential. I won’t accept that :smiley:

Thanks to everyone up untill now for the support, it’s nice here!


#17

Hi,

It could be a USB chipset difference between your old system (fine) and the new one (not fine).

You can also confirm this behaviour ofit working with USB 2 if you have a USB2 hub. Plug hub into USB3 port and sound device into hub and it will probably work.

FYI, here is the Focusrite knowledge base article explaining why they stick with USB 2 and why in practical terms you will probably not benefit from the extra USB3 bandwidth for audio applications.

Mind you, our experience causes us to take issue with the penultimate paragraph.

Happy to help re support, we are a pretty friendly bunch around here, with a common interest and the help given out and experience shared is invaluable. :slight_smile:

It’s a shame we cannot provide a definitive answer, but hopefully the shared experience is useful.


#18

Scratch that, USB 2.0 Also isn’t working anymore. Just freezes after a couple of notes of playing a VST. Can’t get it to function normally. I’m awaiting response from Japan. They need to get their shit together. I have a useless product on my hands. I’m tempted to go to a different brand that has better driver support. Any recommendations? I don’t lke the Zoom software either, it’s gimmicky and glitchy, bad quality. I’m thinking Presonus.


#19

After some more digging I found a thread online about USB 3.1 not working with the Zoom UAC-2. So, I checked the specs on my laptop and the websites that advertise them say 3.0. But when I run hwinfo64 it says 3.1. I looked up the name of the MOBO in hwinfo64 and searched its’ specs online. Well waddayaknow, it’s all USB 3.1, and the Zoom doesn’t likey-like that. So, I’m going to try and use the USB 2.0 port while also giving it dedicated power through it’s 5v input.


#20

USB 2.0/External power supply = No joy. It’s very weird to me that it’s not functioning well on USB 2.0 either. But 3.1 is out of the question. I’ve forwarded it to a person who will forward it to Japan. For now, the Zoom UAC-2 will not work with USB 3.1. I think I’m going to switch to another vendor. It’s just not acceptable that I for some reason cannot do my work anymore because a company doesn’t keep up with developments and is not very forthcoming in terms of customer service, quite frankly customer service is a joke over at Zoom.