Cantabile changing plugin settings whilst playing without prompt?

I’m a new user of Cantabile, using it to play in a pop/rock band. I’m using Cantabile Solo Version 4.0 Build 4062 (x64). My setup is MIDI out from a basic keyboard (with sustain pedal), into a Focusrite Saffire 6 USB audio interface, into a Dell laptop. No ‘MIDI in’ back to the keyboard - just ‘one way’.

I’ve used Cantabile for a few practices before, with no issue. However tonight, I noticed some sounds were changing whilst I was playing. I discovered that my plugins (e.g. AIR Hybrid 3) where changing to a higher or lower setting, without me pressing anything. e.g. “28 Clean Saw Lead” changed to “29 Spirituality”. I haven’t setup anything to do this (I have heard of program changes, but never set one up; and only one song had a binding where the sustain pedal changes the master gain), so I’m not sure what could be triggering these changes?
On songs where I have multiple plugins (either playing concurrently, or with Key Ranges), I saw multiple plugins changed.
I also observed the change hapepning i.e. I double clicked the plugin to load it, and whilst playing it (and nothing touching the laptop) saw it change setting.
I couldn’t see a correlation - it happened after maybe a few seconds or a few minutes. Unplugging the sustain pedal made no difference.
It was happening on multiple songs. Closing Cantabile and reloading the song does restore the correct plugin settings. But we have a gig in 2 weeks, so I’m now a bit nervous as it’s not ideal to restart in the middle of song!

Any ideas what could be causing this? (Let me know if I need to describe the physical setup at all. I will also try to replicate the problem at home over the weekend).
Is there a way to ‘lock’ Cantabile song settings, to play in ‘read only’ mode?

1 Like

Hi Chris,

I also use AIR Hybrid 3 and had a similar experience my first outing with it. My m-audio Axiom 61 sliders were inadvertently changing parameters in the patch.


Thanks Doug, that’s interesting to hear.
My keyboard is a Yamaha np-30, which is really basic - no sliders, or really any controls at all! So I’m not sure that could be it…

Wow, that’s really weird.

First thing I’d check is to see if there’s any MIDI activity arriving at the plugin that might be provoking it to do something:

  • Right click on the plugin slot
  • Choose MIDI Monitor
  • Let the system run and watch for the mysterious changes
  • When they happen take a look at the MIDI Monitor panel and see if anything was sent to the plugin at that time. In particular look out for CC messages that might be internally mapped by the plugin to its settings and/or program change events.

If nothing is showing up on the MIDI monitor and the selected preset in Cantabile’s UI isn’t changing then I’m at a loss and you’d probably need to contact the plugin vendor to see what’s going on.


I’ve made a habit of putting a Suppress Program Change MIDI filter on all my plugin input routes just to avoid any unpleasant surprises that cause me to lose the edits i’m making to a plugin’s parameters. It won’t get to the bottom of what’s happening in your case, but could be a quick workaround.

– Jimbo


Thanks @brad (for everything!). Unfortunately, I can’t replicate the issue. We recorded our practice, and it happened within a 2mins of starting playing… but I’ve been unable to replicate for an hour tonight.
I am now wondering if it was a malfunctioning controller. I tried everything (powercycling laptop, powercycling USB interface, trying different USB input), but don’t think I powercycled the keyboard. Having consulted the manual, it seems like the keyboard can send PC events, and when I change sounds on the keyboard, it does cause the plugin preset to change in Cantabile (i.e. like observed). So this could be “what” (if not “why”!).

@JimboKeys - at this stage, I’m thinking I may never understand the cause! So prevention sounds great. For avoidance of doubt, is it like this?

Yes, that’s exactly how i do it.

I go one step further: for each of my instrument racks, I insert a filter that only explicitly allows the MIDI data that I want the plugin to see.

In this case, the plugin should only see notes, pitch bend, aftertouch and the CCs for modulation and expression. Everything else is blocked.

I’ve seen cases where plugins were completely messed up by CC commands from the control keyboard being accidentally sent and interpreted as parameter change by the plugin (depending on its MIDI implementation), with extremely funky consequences…

These days, I take very good care that only the needed data arrives at the plugin - actually, I do that at multiple points to be sure (input abstraction and routing to racks, then inside the rack as well).



Following with interest as I have the Identical issue with Hybrid 3 using solo 4061,
in a studio setup. similar to how your setup.
I also have the same situation with vacuum pro 64 (another Air vst)

Like Torsten above I also filter out everything that I don’t need at the input. In addition, I explicitly set my input channel rather than leave it at omni, for the same reasons.

When I first started with vst’s, I controlled my instruments from my keyboard layer controls (which worked fine), except, I realized that each key press was sending dupicate MIDI on 4 channels creating significant latency. I bought a small control surface ( a Behringer X-Touch mini), now I send only on channel 1 and do all my splits and other modifications on Cantabile.

I also set my routes to a specific channel going to the plugins.

Note: I bit myself in the posterior the other day, I was trying to play sound internal to my keyboard from Cantabile with the program I want to play assigned to a MIDI channel (which used to work). After too much thrashing around, I realized that I had gotten carried away and set my keyboard out on Cantabile to channel 1, not omni.

Cheers, make fun noises


That’s what I do as well (put in a suppress program change filter), as there is no use case yet where I want to do that when playing live, as I will use state changes to control that.

Well, after putting the recommended filters on, I’ve not seen this since. Absence of evidence isn’t evidence of absence, but so far so good! We got through the gig without issue, so many thanks for the help. If I see it reappear, I’ll post back here, but thanks for now!

I only send notes to the plugins, I use a rack to wrap plugins and bindings within the rack for handling all the CC stuff.

If you always want to filter out program changes or other specific commands, I would recommend that you setup a filter under options/Midi ports for your controller. That way you don’t have to do it everytime you create a new route with that specific controller.

I use a Korg Kronos 88 as master keyboard, where I use the sliders and knobs to control Cantabile from the kronos.

I have 2 ports setup for the kronos:

First port “From Kronos PC” where only midi channel 1 gets through. I use this port strictly for program changes to change the setlist number, no routes is ever created using this port.

Second port “From Kronos” where midi channel 2 to 16 gets through, but filtered to suppress Program changes. I use this port for routes to the the different plugins I use and Channel 16 for controlling Cantabile.

Of course, you can always change things as you go, because Cantabile is extremely flexible.



Welcome to the Forum Tommy,

Thanks for your input and ideas!




Hi Tommy, welcome.

You are depicting something like a Rack with MIDI filter(s) directly at “Options/Midi ports” level.
Am I right?

1 Like

Hi Cpaolo

No, not a rack, but directly setup it up at port level on the controller. There is also a midi filter available there, exactly in the same way as a rack or a route, but if you do it under options/midi ports, it is global.


1 Like

Tommy, I replied you with a silly answer since I didn’t re-read the whole thread. My mess, so. I know about global midi filters in the MIDI settings, but, this time I felt myself a bit dumb.


1 Like

No worries :slightly_smiling_face:

1 Like