Cantabile and Adat


#1

Hi Brad.
I’ve tried using Cantabile several times, and have never been able to get any sound. I used to use a simple programme called “Console” which was extremely easy to use. It had a virtual cables method which I see you have now introduced to Cantabile. This has perked up my interest again.
I can’t remember if it was the case for each time I tried but the last time I tried Cantabile, it wouldn’t recognise the Adat inputs/outputs of my firewire maudio 18/14. I don’t use a Daw, I use a hardware recorder that has Adat which goes to the Maudio. I don’t have any problems with any other standalone sofware using it this way, but some of the software I have needs a vst host. Should Cantabile work with Adat inputs/outputs?
Maybe it was just a bad download? I’m using windows 7 pro service pk 1. i17 with 8 gig of memory.

Many thanks.


#2

I’m not @brad, but Cantabile should work nicely with ADAT inputs / output - it does for me (RME Fireface / Babyface and Behringer ADA8200).

Do you have ASIO drivers for your M-Audio interface? If you want to use inputs and outputs, you definitely need to have ASIO drivers - and select these in Cantabile’s audio engine settings.

Connecting audio ports in Cantabile is a bit of a learning experience, since Cantabile has a two-stage port logic: physical audio ports (e.g. Fireface Analog 1/2) need to be mapped to logical audio ports (e.g. Main Speakers) in Cantabile’s audio port settings --> see @brad’s videos and the Guides section.

Best start with a simple media player, load a file to play and route the output to “Main Speakers” (which you need to have mapped to the right Adat output). Then start playback and check if you can see the meters moving within Cantabile and if you can hear the file being played.

Cheers,

Torsten


#3

Thanks Torsten.
I more or less knew that Cantabile should work with Adat, but now you have confirmed that I will give it another go.

Many thanks for the reply.

Tony.


#4

I, too use Cantabile with ADAT. I use it to run sounds from my live setup to my recording setup using RME Babyface Pro to Presonus. Then in Studio One I have 4 stereo channels for Pianos, Organs, Synths, and Other.

Richard


#5

I’ve got output from ezdrummer but I can only trigger sounds with the mouse. My midi keyboard goes through a hardware sequencer, and then into the maudio 1814. If I use ezdrummer as a standalone everything works fine, so cantabile is not seeing the 1814 midi output. In the getting started guide it shows a welcome to cantabile and a way to configure the 1814. After instaling I didn’t get the welcome or the opportunity to configure. How do I set up things like sample rates midi ins and outs?

Thanks.


#6

Start here:
https://www.cantabilesoftware.com/guides/gettingStarted

These things are mostly on the Tools Menu under Options…

Cantabile will give you a default of “Main Keyboard” MIDI input and “Main Speakers” Audio output. In the Options… setting, there is a section for MIDI ports and one for Audio ports. Best to keep things generic as you start. Go to MIDI ports and setup your MIDI In device as Main Keyboard. Then, set up your Audio device as Main Speakers (you’ll thank me later). The “Audio Engine” tab will have Audio driver, buffers, etc.

After you get that working (baby steps), then consider ADAT or more advanced things. Again, just go with the default names for your first experiments. Almost always, after a few days people delete everything and start over (when they really understand Cantabile). So, don’t spend too much time trying to get it exact and perfect. You will likely want to make Cantabile the hub of all your devices.

Enjoy, Oh, the Guides are really good.

Richard


#7

Thanks Richard.
I found the options menu and was able to get the midi keyboard to work. When I clicked on audio ports all I got was the listed analogue in and outs. No adats?


#8

@Tony What hardware are you using? You have to add them. Go to the Audio Ports tab, and add a device named ADAT. Then, Add 4 Stereo out ports or 8 mono out ports.

Give me a minute and I’ll switch to my RME and do a screen shot…


#9

Here I have a Stereo pair send called “ADAT out A” using hardware port Adat 1 and Adat 2. I created the name “ADAT out A” my Babyface driver provided the name of the hardware “Adat 1”

This is how I defined “ADAT out A”

Then, I added a left and a right to make ADAT out A a stereo pair

Here you can see where the BabyFace driver supplied 4 Analog outputs and 8 ADAT in a drop down.


#10

Pictures are always worth a thousand words. I figure you just saved 4000 words. :grin:


#11

I’m trying to learn from @terrybritton and @dave_dore. Usually, I’m nowhere near my rig. Today I was. Must be a slow day. :sunglasses: :grin:

Of course, @Torsten would have explained it in detail such that it is better than any manual.


#12

Thanks a million for going to all that trouble Richard. That’s going to be so useful when I go back to it tomorrow. I actually managed to get things working earlier, but more by luck than any understanding. Those screen shots will be a brilliant reference. Mostly through user error no doubt, I had a few strange things happen. The strangest of all by far is that my EZdrummer plug in has mysteriously Disappeared without a trace from the vst folder.

Cheers!